freebsd-ports/cad/openvsp/files/patch-src_vsp_CMakeLists.txt
Adriaan de Groot 74c0e748b9 Update CMake to 3.10.1
- https://blog.kitware.com/cmake-3-10-1-available-for-download/
   - flang support
   - changes to automoc policies
   - support for FreeBSD package generation with CPack

Necessary fixes to other ports:
 - cad/openvsp make search for libxml explicit
 - math/scalapack force C compiler to be compatible with mpi
 - deskutils/kdepim4 fix incorrect sources list
 - www/qt5-webkit fix incorrect sources list

Thanks to Antoine for the multiple exp-runs.

PR:		223872
Approved by:	tcberner (mentor)
Differential Revision:	https://reviews.freebsd.org/D13210
2017-12-23 10:44:23 +00:00

15 lines
474 B
Text

Openvsp uses libxml, without explicitly looking for it; in CMake 3.9
this was still OK as some other module included it. That implicit
search has gone away, so add it explicitly where it is used.
--- src/vsp/CMakeLists.txt.orig 2017-09-16 22:18:44 UTC
+++ src/vsp/CMakeLists.txt
@@ -3,6 +3,8 @@ CMAKE_MINIMUM_REQUIRED(VERSION 2.8)
# include the CTest framework
include(CTest)
+find_package(libXml2)
+
IF("${CMAKE_SYSTEM}" MATCHES "Linux")
SET( LINUX_LIBS
pthread