freebsd-ports/multimedia/phonon-xine/files/patch-CMakeLists.txt
Max Brazhnikov 4ac1397e9e Update KDE to 4.2.1.
multimedia/phonon port has been split into phonon itself, phonon-xine
and phono-gstreamer backends. After updating phonon port you have
to install at least one backend. phonon-xine backend is recommended
for KDE.
2009-03-09 00:55:48 +00:00

51 lines
2.1 KiB
Text

--- ./CMakeLists.txt.orig 2009-01-22 11:20:44.000000000 +0300
+++ ./CMakeLists.txt 2009-02-21 01:22:02.000000000 +0300
@@ -127,12 +127,12 @@
try_run(_run_result _compile_result ${CMAKE_BINARY_DIR} ${_source_file} CMAKE_FLAGS "${_include_dirs}")
- if(NOT _compile_result)
- message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
- endif(NOT _compile_result)
- if(_run_result)
- message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
- endif(_run_result)
+# if(NOT _compile_result)
+# message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
+# endif(NOT _compile_result)
+# if(_run_result)
+# message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
+# endif(_run_result)
if (GCC_IS_NEWER_THAN_4_2)
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility-inlines-hidden")
@@ -250,8 +250,8 @@
add_subdirectory(cmake)
-add_subdirectory(phonon)
-add_subdirectory(includes)
+# add_subdirectory(phonon)
+# add_subdirectory(includes)
if (Q_WS_MAC AND BUILD_PHONON_QT7)
add_subdirectory(qt7)
endif (Q_WS_MAC AND BUILD_PHONON_QT7)
@@ -260,13 +260,13 @@
endif (Q_WS_WIN)
if (Q_WS_X11)
- add_subdirectory(gstreamer)
+# add_subdirectory(gstreamer)
add_subdirectory(xine)
endif (Q_WS_X11)
-if(NOT WIN32) # pkgconfig file
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/phonon.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc @ONLY)
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
-endif(NOT WIN32)
+# if(NOT WIN32) # pkgconfig file
+# configure_file(${CMAKE_CURRENT_SOURCE_DIR}/phonon.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc @ONLY)
+# install(FILES ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc DESTINATION ${LIB_INSTALL_DIR}/../libdata/../libdata/../libdata/../libdata/../libdata/pkgconfig)
+# endif(NOT WIN32)
macro_display_feature_log()