4c345ed272
- Use Makefile for building instead of scons, and remove Perl dependency. - Use pkg-plist. - Add OPTIONS. Allow to build without X11, threaded version, etc. - Fix building on non-i386 and FreeBSD 4.X. - Respect CFLAGS when optimizations are enabled. - Add patch to fix 2 security vulnerabilities [1]. PR: ports/98295 Submitted by: alepulver (myself) Approved by: maintainer (timeout) Obtained from: q3icculus (http://icculus.org/quake3/) [1] Security: CVE-2006-2082 [1]
18 lines
655 B
C
18 lines
655 B
C
--- ./code/q3_ui/ui_players.c.orig Wed May 31 20:52:07 2006
|
|
+++ ./code/q3_ui/ui_players.c Wed May 31 20:55:05 2006
|
|
@@ -69,13 +69,13 @@
|
|
|
|
if ( weaponNum == WP_MACHINEGUN || weaponNum == WP_GAUNTLET || weaponNum == WP_BFG ) {
|
|
strcpy( path, item->world_model[0] );
|
|
- COM_StripExtension( path, path );
|
|
+ COM_StripExtension( path, path, sizeof(path) );
|
|
strcat( path, "_barrel.md3" );
|
|
pi->barrelModel = trap_R_RegisterModel( path );
|
|
}
|
|
|
|
strcpy( path, item->world_model[0] );
|
|
- COM_StripExtension( path, path );
|
|
+ COM_StripExtension( path, path, sizeof(path) );
|
|
strcat( path, "_flash.md3" );
|
|
pi->flashModel = trap_R_RegisterModel( path );
|
|
|