freebsd-ports/devel/swarm/files/patch-ac
Ade Lovett b2fd75e438 libtool uber-patch
* kill devel/libtool and move to devel/libtool13, upgrading to 1.3.5
* upgrade repo-copied devel/libtool14 to 1.4.3
* break out libltdl into its own separate port
* move to version-numbered binaries/scripts (ie: there is *no* 'libtool'
  any more -- USE_LIBTOOL and USE_LIBTOOL_VER are your friends)

Approved by:	portmgr (kris) - for the bsd.port.mk hooks
Tested by:	bento 4-exp builds (repeatedly)
2003-06-26 22:58:32 +00:00

57 lines
2.2 KiB
Text

--- configure.orig Sat Mar 25 13:00:14 2000
+++ configure Sun Oct 20 02:30:01 2002
@@ -1306,7 +1306,7 @@
test -n "$OBJC" || OBJC="$CC"
test -n "$OBJCFLAGS" || OBJCFLAGS="$CFLAGS"
-OBJCFLAGS="$OBJCFLAGS -Wall -Wno-import -Wno-protocol -Werror"
+OBJCFLAGS="$OBJCFLAGS -Wall -Wno-import -Wno-protocol"
# Check whether --enable-shared or --disable-shared was given.
@@ -1691,8 +1691,8 @@
LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" \
DLLTOOL="$DLLTOOL" AS="$AS" OBJDUMP="$OBJDUMP" \
-${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
-$libtool_flags --no-verify $ac_aux_dir/ltmain.sh $host \
+${CONFIG_SHELL-/bin/sh} %%LTCONFIG%% --no-reexec \
+$libtool_flags --no-verify --disable-ltlibs %%LTMAIN%% $host \
|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
# Reload cache, that may have been modified by ltconfig
@@ -1706,7 +1706,7 @@
# This can be used to rebuild libtool when needed
-LIBTOOL_DEPS="$ac_aux_dir/ltconfig $ac_aux_dir/ltmain.sh"
+LIBTOOL_DEPS="%%LTCONFIG%% %%LTMAIN%%"
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
@@ -4108,7 +4108,7 @@
echo $ac_n "checking how to avoid implicit int return warning""... $ac_c" 1>&6
echo "configure:4110: checking how to avoid implicit int return warning" >&5
CFLAGS_NOWARN_IMPLICIT_INT=-Wno-implicit-int
-CFLAGS="-Wall -Werror $CFLAGS_NOWARN_IMPLICIT_INT $CFLAGS"
+CFLAGS="-Wall $CFLAGS_NOWARN_IMPLICIT_INT $CFLAGS"
cat > conftest.$ac_ext <<EOF
#line 4114 "configure"
#include "confdefs.h"
@@ -4133,7 +4133,7 @@
echo $ac_n "checking how to avoid unknown pragma warning""... $ac_c" 1>&6
echo "configure:4135: checking how to avoid unknown pragma warning" >&5
CFLAGS_NOWARN_UNKNOWN_PRAGMAS=-Wno-unknown-pragmas
-CFLAGS="-Wall -Werror $CFLAGS_NOWARN_UNKNOWN_PRAGMAS"
+CFLAGS="-Wall $CFLAGS_NOWARN_UNKNOWN_PRAGMAS"
cat > conftest.$ac_ext <<EOF
#line 4139 "configure"
#include "confdefs.h"
@@ -5049,6 +5049,7 @@
JAVAINCLUDES="$JAVAINCLUDES -I$jdkincludedir/freebsd"
threads=green
proc=i386
+ JAVACMD="\${jdkdir}/bin/java"
elif test -f $expand_jdkincludedir/irix/jni_md.h; then
JAVAINCLUDES="$JAVAINCLUDES -I$jdkincludedir/irix"
threads=green