ec4067901a
but doesn't work at the moment.
100 lines
3.1 KiB
Text
100 lines
3.1 KiB
Text
#iZ 28398
|
|
#iZ 11424
|
|
|
|
http://qa.openoffice.org/issues/show_bug.cgi?id=28398
|
|
http://qa.openoffice.org/issues/show_bug.cgi?id=11424
|
|
|
|
diff -u moz/mozilla-source-1.7b.patch moz.new/mozilla-source-1.7b.patch
|
|
--- moz/mozilla-source-1.7b.patch Wed Jul 14 13:22:36 2004
|
|
+++ moz.new/mozilla-source-1.7b.patch Mon Nov 22 18:22:38 2004
|
|
@@ -4447,7 +4447,6 @@
|
|
+#MKSHLIB += -R '$$ORIGIN'
|
|
endif
|
|
endif
|
|
- endif
|
|
|
|
Index: mailnews/addrbook/src/nsAbMD5sum.cpp
|
|
===================================================================
|
|
@@ -5104,3 +5103,81 @@
|
|
+//#define HAVE_MMX_INTEL_MNEMONICS
|
|
+//#define HAVE_SSE2_INTEL_MNEMONICS
|
|
#endif
|
|
+
|
|
+
|
|
+
|
|
+
|
|
+--- misc/build/mozilla/configure.orig Tue Mar 16 13:00:47 2004
|
|
++++ misc/build/mozilla/configure Sat Oct 16 15:59:50 2004
|
|
+@@ -12507,15 +12507,15 @@
|
|
+
|
|
+
|
|
+ if test -z "$GSSAPI_LIBS" ; then
|
|
+- LIBS="$LIBS -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err"
|
|
+- echo $ac_n "checking for gss_init_sec_context in -lgssapi_krb5""... $ac_c" 1>&6
|
|
+-echo "configure:12513: checking for gss_init_sec_context in -lgssapi_krb5" >&5
|
|
+-ac_lib_var=`echo gssapi_krb5'_'gss_init_sec_context | sed 'y%./+-%__p_%'`
|
|
++ LIBS="$LIBS -lkrb5 -lcrypto -lasn1 -lcom_err -lroken -lgssapi -lcrypt"
|
|
++ echo $ac_n "checking for gss_init_sec_context in -lgssapi""... $ac_c" 1>&6
|
|
++echo "configure:12513: checking for gss_init_sec_context in -lgssapi" >&5
|
|
++ac_lib_var=`echo gssapi'_'gss_init_sec_context | sed 'y%./+-%__p_%'`
|
|
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
|
|
+ echo $ac_n "(cached) $ac_c" 1>&6
|
|
+ else
|
|
+ ac_save_LIBS="$LIBS"
|
|
+-LIBS="-lgssapi_krb5 $LIBS"
|
|
++LIBS="-lgssapi $LIBS"
|
|
+ cat > conftest.$ac_ext <<EOF
|
|
+ #line 12521 "configure"
|
|
+ #include "confdefs.h"
|
|
+@@ -12543,7 +12543,7 @@
|
|
+ fi
|
|
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
|
|
+ echo "$ac_t""yes" 1>&6
|
|
+- GSSAPI_LIBS="-L$GSSAPI_DIR/lib -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err"
|
|
++ GSSAPI_LIBS="-L$GSSAPI_DIR/lib -lgssapi -lkrb5 -lasn1 -lroken -lcrypto -lcom_err -lcrypt"
|
|
+ else
|
|
+ echo "$ac_t""no" 1>&6
|
|
+ fi
|
|
+@@ -12653,7 +12653,7 @@
|
|
+ cat > conftest.$ac_ext <<EOF
|
|
+ #line 12655 "configure"
|
|
+ #include "confdefs.h"
|
|
+- #include <gssapi/gssapi.h>
|
|
++ #include <gssapi.h>
|
|
+ int main() {
|
|
+ gss_OID oid = GSS_C_NT_HOSTBASED_SERVICE;
|
|
+ ; return 0; }
|
|
+
|
|
+ endif
|
|
+
|
|
+--- misc/build/mozilla/directory/c-sdk/ldap/libraries/libldap/Makefile.in.org Fri Oct 22 22:43:46 2004
|
|
++++ misc/build/mozilla/directory/c-sdk/ldap/libraries/libldap/Makefile.in Fri Oct 22 22:44:01 2004
|
|
+@@ -225,6 +225,10 @@
|
|
+ EXTRA_LIBS = -L$(dist_libdir) -l$(LBER_LIBNAME) -lbe
|
|
+ endif
|
|
+
|
|
++ifeq ($(OS_ARCH), FreeBSD)
|
|
++EXTRA_LIBS = -L$(dist_libdir) -l$(LBER_LIBNAME)
|
|
++endif
|
|
++
|
|
+ ifeq ($(OS_ARCH), NetBSD)
|
|
+ EXTRA_LIBS = -L$(dist_libdir) -l$(LBER_LIBNAME)
|
|
+ endif
|
|
+
|
|
+
|
|
+--- misc/build/mozilla/extensions/negotiateauth/nsHttpGssapiAuth.cpp.org Tue Mar 16 09:34:01 2004
|
|
++++ misc/build/mozilla/extensions/negotiateauth/nsHttpGssapiAuth.cpp Mon Nov 22 18:21:07 2004
|
|
+@@ -289,7 +289,7 @@
|
|
+ return NS_OK;
|
|
+ }
|
|
+
|
|
+-NS_IMPL_ISUPPORTS1(nsHttpGssapiAuth, nsIHttpAuthenticator);
|
|
++NS_IMPL_ISUPPORTS1(nsHttpGssapiAuth, nsIHttpAuthenticator)
|
|
+
|
|
+ //
|
|
+ // GenerateCredentials
|
|
+
|
|
+
|
|
+
|
|
+
|
|
+
|