freebsd-ports/math/metis/files/patch-libmetis__CMakeLists.txt
Thierry Thomas 4291c7c5df Since the upgrade of math/suitesparse to 5.2.0, it depends unconditionnaly on
math/metis. Because math/metis and math/metis-edf are conflicting, this means
that the ports which depend on SuiteSparse and on metis-edf became BROKEN.

To solve this problem, this revision adds the missings includes brought by
metis-edf to metis.

Note for myself: if everything goes well, do not forget to deprecate the port
math/metis-edf in a near future.
2018-05-06 08:15:59 +00:00

23 lines
689 B
Text

--- libmetis/CMakeLists.txt.orig 2013-03-30 16:24:45 UTC
+++ libmetis/CMakeLists.txt
@@ -2,8 +2,13 @@
include_directories(.)
# Find sources.
file(GLOB metis_sources *.c)
+# Borrowed from metis-edf
+file(GLOB libmetis_h *.h)
# Build libmetis.
add_library(metis ${METIS_LIBRARY_TYPE} ${GKlib_sources} ${metis_sources})
+if(SHARED)
+ set_target_properties(metis PROPERTIES SOVERSION ${SHLIB_MAJOR})
+endif()
if(UNIX)
target_link_libraries(metis m)
endif()
@@ -13,4 +18,6 @@ if(METIS_INSTALL)
LIBRARY DESTINATION lib
RUNTIME DESTINATION lib
ARCHIVE DESTINATION lib)
+# Borrowed from metis-edf
+ install(FILES ${libmetis_h} DESTINATION include/libmetis)
endif()