freebsd-ports/games/orbital_eunuchs_sniper/files/patch-src-Makefile.in
Alejandro Pulver 72658dc246 - Update to version 1.30.
- This version fixes a startup crash [1].
- Add a patch to fix crash when resuming from a paused game.

PR:		ports/116140 [1]
Submitted by:	Edwin Groothuis <edwin@mavetju.org>
2007-10-01 00:45:35 +00:00

23 lines
1,002 B
Text

--- ./src/Makefile.in.orig Thu Oct 19 00:38:42 2006
+++ ./src/Makefile.in Sun Sep 30 21:02:31 2007
@@ -38,8 +38,7 @@
build_triplet = @build@
host_triplet = @host@
target_triplet = @target@
-pkgdata_PROGRAMS = snipe2d.@CPU_IS@.dynamic$(EXEEXT) \
- snipe2d.@CPU_IS@.static$(EXEEXT)
+pkgdata_PROGRAMS = snipe2d-bin$(EXEEXT)
subdir = src
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in \
$(srcdir)/snipe2d.in
@@ -275,8 +274,8 @@
clean-pkgdataPROGRAMS:
-test -z "$(pkgdata_PROGRAMS)" || rm -f $(pkgdata_PROGRAMS)
-snipe2d.@CPU_IS@.dynamic$(EXEEXT): $(snipe2d_@CPU_IS@_dynamic_OBJECTS) $(snipe2d_@CPU_IS@_dynamic_DEPENDENCIES)
- @rm -f snipe2d.@CPU_IS@.dynamic$(EXEEXT)
+snipe2d-bin$(EXEEXT): $(snipe2d_@CPU_IS@_dynamic_OBJECTS) $(snipe2d_@CPU_IS@_dynamic_DEPENDENCIES)
+ @rm -f snipe2d-bin$(EXEEXT)
$(CXXLINK) $(snipe2d_@CPU_IS@_dynamic_LDFLAGS) $(snipe2d_@CPU_IS@_dynamic_OBJECTS) $(snipe2d_@CPU_IS@_dynamic_LDADD) $(LIBS)
install-binSCRIPTS: $(bin_SCRIPTS)
@$(NORMAL_INSTALL)