freebsd-ports/www/mod_layout22/files/patch-Makefile
Christian Weisgerber 5153f5fc0a * Update to 4.0.2a
* Use LATEST_LINK

PR:		57178
Submitted by:	Clement Laforet <sheepkiller@cultdeadsheep.org>
2003-09-26 17:25:14 +00:00

35 lines
1.2 KiB
Text

--- Makefile.orig Wed Sep 24 17:56:08 2003
+++ Makefile Wed Sep 24 17:56:33 2003
@@ -1,13 +1,13 @@
##
## Makefile -- Build procedure for mod_layout Apache module
##
-builddir=$(shell pwd)
-top_srcdir=/usr/local/apache2
-top_builddir=/usr/local/apache2
-include /usr/local/apache2/build/special.mk
+#builddir=$(shell pwd)
+top_srcdir=${LOCALBASE}/share/apache2
+top_builddir=${LOCALBASE}/share/apache2
+include ${LOCALBASE}/share/apache2/build/special.mk
# the used tools
-APXS=apxs
+APXS=${LOCALBASE}/sbin/apxs
APACHECTL=apachectl
CC=`$(APXS) -q CC`
INC=-I`$(APXS) -q INCLUDEDIR` `$(APXS) -q CFLAGS` #-DLAYOUT_FILEOWNER_NAME
@@ -61,12 +61,7 @@
$(APXS) -c header.c
# install the shared object file into Apache
install:
- $(APXS) -iac $(INCLUDES) $(LIBS) $(SRC)
- @echo "+--------------------------------------------------------+"; \
- echo "| All done. |"; \
- echo "| |"; \
- echo "| Thanks for installing mod_layout. |"; \
- echo "+--------------------------------------------------------+"; \
+ $(APXS) -ia $(INCLUDES) $(LIBS) mod_layout.la
rpm: dist
cp $(DISTVNAME).tar$(SUFFIX) /usr/src/redhat/SOURCES