freebsd-ports/devel/libfastcommon/files/patch-src_Makefile.in
John Marino eade84d0d7 devel/libfastcommon: fix misbuild, add DF, bump deps minus nginx-full
The fastcommon library is being built as 32-bit on amd64 due to the
misuse of uname (uname -p returns "amd64", not uname alone).

Additionally, the hardcoded install commands (added via patch) have been
updated to the BSD_INSTALL* macros to satisfy QA tests.

While here, fix building on DragonFly (sacrificing unused Darwin support
in the process).

Finally, bump all ports dependend on fault libfastcommon.so except
www/nginx-full which has no separate PORTREVISION setting.  I can't bump
it without bumping www/nginx too (bug??).

Approvd by:	just-fix-it
2017-01-28 14:22:53 +00:00

28 lines
1.1 KiB
Text

--- src/Makefile.in.orig 2016-09-08 07:44:31 UTC
+++ src/Makefile.in
@@ -41,7 +41,7 @@ ALL_LIBS = $(SHARED_LIBS) $(STATIC_LIBS)
all: $(ALL_OBJS) $(ALL_PRGS) $(ALL_LIBS)
libfastcommon.so:
- $(COMPILE) -o $@ $< -shared $(FAST_SHARED_OBJS) $(LIB_PATH)
+ $(COMPILE) -o $@ $< -shared -Wl,-soname,libfastcommon.so $(FAST_SHARED_OBJS) $(LIB_PATH)
libfastcommon.a: $(FAST_STATIC_OBJS)
ar rcs $@ $(FAST_STATIC_OBJS)
.o:
@@ -53,12 +53,10 @@ libfastcommon.a: $(FAST_STATIC_OBJS)
.c.lo:
$(COMPILE) -c -fPIC -o $@ $< $(INC_PATH)
install:
- mkdir -p $(DESTDIR)/usr/$(LIB_VERSION)
- mkdir -p $(DESTDIR)/usr/lib
- install -m 755 $(SHARED_LIBS) $(DESTDIR)/usr/$(LIB_VERSION)
- install -m 755 $(SHARED_LIBS) $(DESTDIR)/usr/lib
- mkdir -p $(DESTDIR)/usr/include/fastcommon
- install -m 644 $(HEADER_FILES) $(DESTDIR)/usr/include/fastcommon
+ mkdir -p $(DESTDIR)$(PREFIX)/$(LIB_VERSION)
+ ${BSD_INSTALL_LIB} $(SHARED_LIBS) $(DESTDIR)$(PREFIX)/$(LIB_VERSION)
+ mkdir -p $(DESTDIR)$(PREFIX)/include/fastcommon
+ ${BSD_INSTALL_DATA} $(HEADER_FILES) $(DESTDIR)$(PREFIX)/include/fastcommon
clean:
rm -f $(ALL_OBJS) $(ALL_PRGS) $(ALL_LIBS)