freebsd-ports/multimedia/vdr-plugin-iptv/files/patch-Makefile
Juergen Lock 47452dcb43 - Finally stagify the vdr ports. \o/
- Use new LIB_DEPENDS syntax.
- Change multimedia/vdr-plugins defaults and bump PORTREVISION for it.
  (switch from xvdr to vnsiserver and disable plugins depending on ffmpeg0)
2014-03-01 12:21:13 +00:00

28 lines
803 B
Text

--- a/Makefile
+++ b/Makefile
@@ -12,7 +12,8 @@
STRIP = strip
# Install command
-INSTALL = cp --remove-destination
+#INSTALL = cp --remove-destination
+INSTALL = cp -f
# The official name of this plugin.
# This name will be used in the '-P...' option of VDR to load the plugin.
@@ -58,7 +58,8 @@ PACKAGE = vdr-$(ARCHIVE)
### Includes and Defines (add further entries here):
-INCLUDES += -I$(VDRDIR)/include
+#INCLUDES += -I$(VDRDIR)/include
+INCLUDES += -I$(VDRDIR)
DEFINES += -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
@@ -148,3 +149,5 @@ clean:
cppcheck: $(OBJS)
@cppcheck --enable=information,style,unusedFunction -v -f $(OBJS:%.o=%.c)
+install:
+ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) ${DESTDIR}$(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)