freebsd-ports/sysutils/moreutils/files/patch-Makefile
Sunpoet Po-Chuan Hsieh 872654feb2 - Move parallel and its manpage to sysutils/moreutils-parallel
- Remove CONFLICTS
- Bump PORTREVISION

PR:		ports/152971
Submitted by:	Charlie Kester <corky1951@comcast.net> (maintainer)
2010-12-16 16:31:11 +00:00

74 lines
1.7 KiB
Text

--- ./Makefile.orig 2010-10-29 12:47:09.000000000 -0700
+++ ./Makefile 2010-11-17 16:02:08.000000000 -0800
@@ -1,51 +1,35 @@
-BINS=isutf8 ifdata ifne pee sponge mispipe lckdo parallel
+BINS=isutf8 ifne pee sponge mispipe lckdo
PERLSCRIPTS=vidir vipe ts combine zrun chronic
-MANS=sponge.1 vidir.1 vipe.1 isutf8.1 ts.1 combine.1 ifdata.1 ifne.1 pee.1 zrun.1 chronic.1 mispipe.1 lckdo.1 parallel.1
-CFLAGS=-O2 -g -Wall
+MANS=sponge.1 isutf8.1 ifne.1 pee.1 mispipe.1 lckdo.1
+CFLAGS+= -Wall
INSTALL_BIN?=install -s
-PREFIX=/usr
-DOCBOOK2XMAN=docbook2x-man
+
+.SUFFIXES: .1 .docbook
+
+DOCBOOK2XMAN= ${LOCALBASE}/bin/xsltproc ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl
all: $(BINS) $(MANS)
+
+bins: ${BINS}
+
+mans: ${MANS}
clean:
rm -f $(BINS) $(MANS)
install:
- mkdir -p $(DESTDIR)$(PREFIX)/bin
- $(INSTALL_BIN) $(BINS) $(DESTDIR)$(PREFIX)/bin
- install $(PERLSCRIPTS) $(DESTDIR)$(PREFIX)/bin
+ mkdir -p $(PREFIX)/bin
+ $(INSTALL_BIN) $(BINS) $(PREFIX)/bin
+ install $(PERLSCRIPTS) $(PREFIX)/bin
- mkdir -p $(DESTDIR)$(PREFIX)/share/man/man1
- install $(MANS) $(DESTDIR)$(PREFIX)/share/man/man1
-
check: isutf8
./check-isutf8
-isutf8.1: isutf8.docbook
- $(DOCBOOK2XMAN) $<
-
-ifdata.1: ifdata.docbook
- $(DOCBOOK2XMAN) $<
-
-ifne.1: ifne.docbook
- $(DOCBOOK2XMAN) $<
-
-pee.1: pee.docbook
- $(DOCBOOK2XMAN) $<
-
-sponge.1: sponge.docbook
- $(DOCBOOK2XMAN) $<
-
-mispipe.1: mispipe.docbook
- $(DOCBOOK2XMAN) $<
-
-lckdo.1: lckdo.docbook
- $(DOCBOOK2XMAN) $<
-
-parallel.1: parallel.docbook
- $(DOCBOOK2XMAN) $<
+.docbook.1:
+ $(DOCBOOK2XMAN) ${.IMPSRC}
-%.1: %
- pod2man --center=" " --release="moreutils" $< > $@;
+extraman: ${PERLSCRIPTS}
+.for i in ${PERLSCRIPTS}
+ pod2man --center=" " --release="moreutils" ${i} > ${i:S@$@.1$@};
+.endfor