freebsd-ports/science/felt/files/patch-src__Burlap__felt.c
Rong-En Fan 162005da10 - Fix build
- Use macro from bsd.sites.mk
- Remove USE_X_PREFIX
- Things in EXAMPLESDIR are controlled by PORTEXAMPLES, not PORTDOCS

PR:		ports/115396
Submitted by:	KATO Tsuguru <tkato432 at yahoo.com>
2007-08-15 14:47:19 +00:00

20 lines
535 B
C

--- src/Burlap/felt.c.orig Tue Feb 22 07:44:30 2000
+++ src/Burlap/felt.c Sat Aug 4 22:27:50 2007
@@ -1780,7 +1780,7 @@
D_Type (d) = T_Problem;
D_Temp (d) = F_False;
D_Trapped (d) = F_False;
- D_Problem (d) = &problem;
+ d->u.ptr = &problem;
s = add_literal (&var_st, "analysis", GlblOp);
@@ -1789,7 +1789,7 @@
D_Type (d) = T_Analysis;
D_Temp (d) = F_False;
D_Trapped (d) = F_False;
- D_Analysis (d) = &analysis;
+ d->u.ptr = &analysis;
return 0;
}