freebsd-ports/net/glusterfs/files/patch-libglusterfs_src_Makefile.am
Timur I. Bakeyev 93be2a4f8f An update to the net/glusterfs port:
- System call fixes backported from upstream
- Adding missing scripts to the SHEBANG_FILES list
- Correct a bug with extended attributes
- Fix detection of the PACKAGE_VERSION and generation of the correct API version

PR:		249492
Submitted by:	maintainer
Reported by:	timur
2020-09-26 21:09:13 +00:00

12 lines
577 B
Text

--- libglusterfs/src/Makefile.am.orig 2020-07-06 01:22:37 UTC
+++ libglusterfs/src/Makefile.am
@@ -12,7 +12,8 @@ libglusterfs_la_CPPFLAGS = $(GF_CPPFLAGS) -D__USE_FILE
-DSBIN_DIR=\"$(sbindir)\" -I$(CONTRIBDIR)/timer-wheel \
-I$(CONTRIBDIR)/xxhash
-libglusterfs_la_LIBADD = $(ZLIB_LIBS) $(MATH_LIB) $(UUID_LIBS)
+libglusterfs_la_LIBADD = $(ZLIB_LIBS) $(MATH_LIB) $(UUID_LIBS) $(LIB_DL) \
+ $(URCU_LIBS) $(URCU_CDS_LIBS)
libglusterfs_la_LDFLAGS = -version-info $(LIBGLUSTERFS_LT_VERSION) $(GF_LDFLAGS) \
-export-symbols $(top_srcdir)/libglusterfs/src/libglusterfs.sym