freebsd-ports/lang/python31/files/patch-setup.py
Hye-Shik Chang 62e80c6399 - Include pyexpat module in python base ports because python incorporated
expat 1.95.6 in its distribution from Python-2.3.
- Bump PORTREVISION subsequently.

Requested by:	Mike Brown <mike@skew.org>
		Jeremy Kloth <jeremy.kloth@fourthought.com>
2003-11-04 18:00:37 +00:00

29 lines
1 KiB
Python

--- setup.py.orig Wed Oct 22 00:41:15 2003
+++ setup.py Thu Oct 30 06:21:21 2003
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
# This global variable is used to hold the list of modules to be disabled.
-disabled_module_list = []
+disabled_module_list = ["_bsddb", "_tkinter", "gdbm", "mpz"]
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
@@ -770,7 +770,7 @@
# Linux-specific modules
exts.append( Extension('linuxaudiodev', ['linuxaudiodev.c']) )
- if platform in ('linux2', 'freebsd4'):
+ if platform in ('linux2', 'freebsd4', 'freebsd5'):
exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
if platform == 'sunos5':
@@ -1140,7 +1140,7 @@
ext_modules=[Extension('struct', ['structmodule.c'])],
# Scripts to install
- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle']
+ scripts = []
)
# --install-platlib