freebsd-ports/x11-servers/XFree86-4-Server/files/patch-trident_driver.c
Dejan Lesjak 2552b8e5f9 Upgrade to XFree86 4.5.0.
Ports changes:
- Drop dependency on x11/wrapper. X server already contains this code
(programs/Xserver/os/utils.c rev. 3.58).
- Install default SecurityPolicy with XFree86-4-libraries, thus avoiding
plists and who-owns-what complications between different fooServer ports.
Copy default file to real one if that doesn't exist and remove both upon
uninstall if they are the same.
- Revert change to Imake.rules rev. 3.132 in devel/imake-4 port, since
couple of ports break with this change
(devel/imake-4/files/patch-Imake.rules)
- Add grehans patches for PPC [1]
- Several of directories that were previously in /etc/mtree/BSD.x11-4.dist
were moved to respective ports pkg-plists

PR:		[1] 78345, 78346, 78348, 78352, 78353, 78354, 78355, 78356
2005-06-15 02:40:03 +00:00

17 lines
713 B
C

Index: programs/Xserver/hw/xfree86/drivers/trident/trident_driver.c
===================================================================
RCS file: /usr/local/repos/xfree86/xc/programs/Xserver/hw/xfree86/drivers/trident/trident_driver.c,v
retrieving revision 1.193
retrieving revision 1.194
diff -u -r1.193 -r1.194
--- programs/Xserver/hw/xfree86/drivers/trident/trident_driver.c 18 Feb 2005 02:55:10 -0000 1.193
+++ programs/Xserver/hw/xfree86/drivers/trident/trident_driver.c 30 Apr 2005 17:04:00 -0000 1.194
@@ -2606,7 +2606,7 @@
TRIDENTPtr pTrident = TRIDENTPTR(pScrn);
TRIDENTRegPtr tridentReg;
- WAITFORVSYNC;
+ if (!xf86IsPc98()) WAITFORVSYNC;
TridentFindClock(pScrn,mode->Clock);