65 lines
1.9 KiB
Text
65 lines
1.9 KiB
Text
--- as/Makefile.orig 1992-04-23 04:04:42 UTC
|
|
+++ as/Makefile
|
|
@@ -1,27 +1,18 @@
|
|
-CFLAGS =-O
|
|
+.include "../Makefile.inc"
|
|
+.PATH: ../ld
|
|
+
|
|
+CFLAGS +=-Wall
|
|
LDFLAGS =
|
|
|
|
-OBJS =as.o assemble.o error.o express.o \
|
|
- genbin.o genlist.o genobj.o gensym.o \
|
|
- macro.o mops.o pops.o readsrc.o \
|
|
- scan.o table.o typeconv.o
|
|
+SRCS =as.c assemble.c error.c express.c \
|
|
+ genbin.c genlist.c genobj.c gensym.c \
|
|
+ macro.c mops.c pops.c readsrc.c \
|
|
+ scan.c table.c typeconv.c
|
|
|
|
-as: $(OBJS)
|
|
- $(CC) $(LDFLAGS) $(OBJS) -o as
|
|
- chmem =182000 as
|
|
+PROG =as86
|
|
|
|
-as.o: const.h type.h byteord.h macro.h file.h flag.h globvar.h
|
|
-assemble.o: const.h type.h address.h globvar.h opcode.h scan.h
|
|
-error.o: const.h type.h
|
|
-express.o: const.h type.h address.h globvar.h scan.h source.h
|
|
-genbin.o: const.h type.h address.h file.h globvar.h
|
|
-genlist.o: const.h type.h address.h flag.h file.h globvar.h macro.h scan.h \
|
|
- source.h
|
|
-genobj.o: const.h type.h address.h file.h globvar.h
|
|
-gensym.o: const.h type.h flag.h file.h globvar.h
|
|
-macro.o: const.h type.h globvar.h scan.h macro.h
|
|
-mops.o: const.h type.h globvar.h opcode.h scan.h address.h
|
|
-pops.o: const.h type.h address.h flag.h globvar.h opcode.h scan.h
|
|
-readsrc.o: const.h type.h flag.h file.h globvar.h macro.h scan.h source.h
|
|
-scan.o: const.h type.h globvar.h scan.h
|
|
-table.o: const.h type.h globvar.h opcode.h scan.h
|
|
+BINDIR = ${LOCALPREFIX}/bin
|
|
+MANDIR = ${LOCALPREFIX}/man/man
|
|
+
|
|
+
|
|
+.include <bsd.prog.mk>
|
|
--- as/as.c.orig 1993-07-10 19:03:52 UTC
|
|
+++ as/as.c
|
|
@@ -7,7 +7,6 @@
|
|
|
|
#include "const.h"
|
|
#include "type.h"
|
|
-#include "byteord.h"
|
|
#include "macro.h"
|
|
#undef EXTERN
|
|
#define EXTERN
|
|
@@ -37,6 +36,10 @@
|
|
#include <unistd.h>
|
|
#endif
|
|
|
|
+/* BSD #defines this in <machine/endian.h>, but with another sense */
|
|
+#undef BIG_ENDIAN
|
|
+#include "byteord.h"
|
|
+
|
|
PUBLIC char hexdigit[] = "0123456789ABCDEF"; /* XXX - ld uses lower case */
|
|
|
|
PRIVATE struct block_s hid_blockstak[MAXBLOCK]; /* block stack */
|