56 lines
1.4 KiB
Text
56 lines
1.4 KiB
Text
--- ld/Makefile.orig 1994-02-19 22:32:12 UTC
|
|
+++ ld/Makefile
|
|
@@ -1,18 +1,18 @@
|
|
-CFLAGS =-O -DBSD_A_OUT -DSTANDARD_GNU_A_OUT
|
|
-LDFLAGS =-N -s
|
|
+.include "../Makefile.inc"
|
|
|
|
-OBJS =dumps.o io.o ld.o readobj.o table.o typeconv.o writebin.o
|
|
+CFLAGS +=-DBSD_A_OUT -DSTANDARD_GNU_A_OUT
|
|
+CFLAGS +=-Wall
|
|
+LDFLAGS =
|
|
|
|
-ld: $(OBJS)
|
|
- $(CC) $(LDFLAGS) $(OBJS) -o $@
|
|
+SRCS =dumps.c io.c ld.c readobj.c table.c typeconv.c writebin.c
|
|
|
|
-clean:
|
|
- rm -f $(OBJS) ld
|
|
+PROG =ld86
|
|
|
|
-dumps.o: dumps.c const.h config.h obj.h type.h globvar.h
|
|
-io.o: io.c const.h config.h obj.h type.h globvar.h
|
|
-ld.o: ld.c const.h config.h byteord.h type.h globvar.h
|
|
-readobj.o: readobj.c const.h config.h byteord.h obj.h type.h globvar.h
|
|
-table.o: table.c const.h config.h align.h obj.h type.h globvar.h
|
|
-typeconv.o: typeconv.c const.h config.h type.h globvar.h
|
|
-writebin.o: writebin.c const.h config.h obj.h type.h globvar.h
|
|
+BINDIR =${LOCALPREFIX}/bin
|
|
+MANDIR =${LOCALPREFIX}/man/man
|
|
+
|
|
+beforeinstall:
|
|
+ -mkdir -p ${DESTDIR}${BINDIR}
|
|
+ -mkdir -p ${DESTDIR}${MANDIR}1
|
|
+
|
|
+.include <bsd.prog.mk>
|
|
--- ld/ld.c.orig 1994-02-19 22:36:05 UTC
|
|
+++ ld/ld.c
|
|
@@ -3,7 +3,6 @@
|
|
/* Copyright (C) 1994 Bruce Evans */
|
|
|
|
#include "const.h"
|
|
-#include "byteord.h"
|
|
#include "type.h"
|
|
#include "globvar.h"
|
|
|
|
@@ -26,6 +25,10 @@
|
|
#include <unistd.h>
|
|
#endif
|
|
|
|
+/* BSD #defines this in <machine/endian.h>, but with another sense */
|
|
+#undef BIG_ENDIAN
|
|
+#include "byteord.h"
|
|
+
|
|
#define MAX_LIBS (NR_STDLIBS + 5)
|
|
#define NR_STDLIBS 1
|
|
|