2f4c3550c5
- update firefox-esr, thunderbird-esr, linux-thunderbird and linux-firefox to 10.0.7 - update seamonkey and linux-seamonkey to 2.12 - update nss to 3.13.6 - update bsdipc code (posix_spawn, SysV shared memory) - rename patches to easily track those not (yet) submitted upstream - reduce package size, except for www/libxul[1] - restore default objdir to what it was in 13.0 - fix mail/enigmail after thunderbird build changes - don't accidentally pick up headers from installed ports[3] - add support for PREFIX != LOCALBASE to Makefile.webplugins [4] - document vulnerabilities in vuln.xml - *miscellaneous cleanups and fixups* Obtained from: OpenBSD ports[1] PR: ports/159831, ports/160933, ports/170467[3], ports/170236 [4] Submitted by: avilla [4] In collaboration with: Jan Beich <jbeich@tormail.net> Who did most of the hard work.
13 lines
675 B
Text
13 lines
675 B
Text
$OpenBSD: patch-toolkit_mozapps_installer_packager_mk,v 1.11 2012/06/11 15:29:56 landry Exp $
|
|
install headers/idl/sdk libs only if xulrunner
|
|
--- toolkit/mozapps/installer/packager.mk.orig Fri Jun 1 14:04:20 2012
|
|
+++ toolkit/mozapps/installer/packager.mk Tue Jun 5 07:55:51 2012
|
|
@@ -886,7 +886,7 @@ endif
|
|
$(NSINSTALL) -D $(DESTDIR)$(bindir)
|
|
$(RM) -f $(DESTDIR)$(bindir)/$(MOZ_APP_NAME)
|
|
ln -s $(installdir)/$(MOZ_APP_NAME) $(DESTDIR)$(bindir)
|
|
-ifdef INSTALL_SDK # Here comes the hard part
|
|
+ifeq ($(MOZ_APP_NAME),xulrunner)
|
|
$(NSINSTALL) -D $(DESTDIR)$(includedir)
|
|
(cd $(DIST)/include && tar $(TAR_CREATE_FLAGS) - .) | \
|
|
(cd $(DESTDIR)$(includedir) && tar -xf -)
|