59 lines
1.7 KiB
Text
59 lines
1.7 KiB
Text
--- src/Makefile.orig Sun Dec 14 20:37:51 2003
|
|
+++ src/Makefile Thu May 6 12:16:48 2004
|
|
@@ -1,49 +1,8 @@
|
|
-BIN = mathopd
|
|
-CC = gcc
|
|
-CFLAGS = -O -Wall
|
|
-CPPFLAGS =
|
|
-LDFLAGS =
|
|
-LIBS = -lcrypt
|
|
-PREFIX = /usr/local
|
|
-SBINDIR = $(PREFIX)/sbin
|
|
+PROG= mathopd
|
|
+SRCS= base64.c cgi.c config.c core.c dump.c imap.c log.c \
|
|
+ main.c redirect.c request.c util.c stub.c sendfile.c
|
|
+BINDIR?=${PREFIX}/sbin
|
|
+NOMAN= yes
|
|
+LDADD= -lcrypt
|
|
|
|
-# On Solaris, uncomment the following
|
|
-# CPPFLAGS = -DNEED_INET_ATON -DHAVE_CRYPT_H
|
|
-# LIBS = -lsocket -lnsl
|
|
-
|
|
-# On Linux, uncomment the following
|
|
-# CPPFLAGS = -DHAVE_CRYPT_H
|
|
-
|
|
-OBJS = base64.o cgi.o config.o core.o dump.o imap.o log.o main.o \
|
|
- redirect.o request.o util.o stub.o
|
|
-DEPENDS = mathopd.h Makefile
|
|
-
|
|
-# Uncomment the following if your system does not support the poll() function
|
|
-# CPPFLAGS += -DPOLL_EMULATION
|
|
-# OBJS += poll-emul.o
|
|
-
|
|
-# Uncomment the following if your system does not have the socklen_t type
|
|
-# CPPFLAGS += -DNEED_SOCKLEN_T
|
|
-
|
|
-# Unomment the following if your system has a working vfork() function
|
|
-# CPPFLAGS += -DHAVE_VFORK
|
|
-
|
|
-# Currently, sendfile support is available in two flavours: Linux and FreeBSD
|
|
-# Uncomment one of the following two to enable sendfile() support
|
|
-# CPPFLAGS += -DLINUX_SENDFILE
|
|
-# CPPFLAGS += -DFREEBSD_SENDFILE
|
|
-# If you define any of the SENDFILE conditionals, make sure to uncomment
|
|
-# the next line as well.
|
|
-# OBJS += sendfile.o
|
|
-
|
|
-all: $(BIN)
|
|
-install: $(BIN)
|
|
- install -c $(BIN) $(SBINDIR)
|
|
-$(BIN): $(OBJS)
|
|
- $(CC) $(LDFLAGS) -o $(BIN) $(OBJS) $(LIBS)
|
|
-$(OBJS): $(DEPENDS)
|
|
-.c.o:
|
|
- $(CC) -c $(CFLAGS) $(CPPFLAGS) $< -o $@
|
|
-clean:
|
|
- rm -f $(BIN) $(OBJS)
|
|
-.PHONY: install clean
|
|
+.include <bsd.prog.mk>
|