freebsd-ports/editors/openoffice.org-2-RC/files/patch-mozillasrc::makefile.mk
Martin Blapp b51761e90d Revert the last change. It looks like -fno-rtti is only needed for the
mozilla part, and else it breaks the build where -rtti is used. Add a new
patch to change it for the mozilla build.
2002-03-16 17:02:10 +00:00

13 lines
398 B
Makefile

--- ../connectivity/source/drivers/mozab/mozillasrc/makefile.mk.orig Fri Mar 15 19:10:28 2002
+++ ../connectivity/source/drivers/mozab/mozillasrc/makefile.mk Fri Mar 15 19:11:45 2002
@@ -152,6 +152,10 @@
-Wno-long-long -pthread
CDEFS += -DTRACING
.ENDIF
+.IF "$(OS)" == "FREEBSD"
+CFLAGSCXX += \
+ -fno-rtti
+.ENDIF
.ENDIF
SHL1TARGET_NAME=$(TARGET)$(MOZAB_MAJOR)