2670921f55
- Change installation handling for executable - Recreate patches with make makepatch
31 lines
989 B
Text
31 lines
989 B
Text
--- ./JLib/Makefile.orig 2009-05-02 11:17:15.000000000 +0200
|
|
+++ ./JLib/Makefile 2014-05-06 09:39:45.658916968 +0200
|
|
@@ -19,7 +19,7 @@
|
|
endif
|
|
|
|
# Define -D_JLIB_DEBUG to debug JLib. Compile the app to debug also with this flag
|
|
-CFLAGS=-I. -I/usr/local/include/SDL -O3 -ffast-math -fPIC -Wall -Wshadow `$(SDL_CONFIG) --cflags`
|
|
+CXXFLAGS+=-I. -fPIC -Wall -Wshadow `$(SDL_CONFIG) --cflags`
|
|
|
|
# Sample LDFLAGS for applications
|
|
# LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
|
|
@@ -28,15 +28,15 @@
|
|
|
|
# JLib
|
|
libJLib: $(JLIB_OBJS)
|
|
- g++-4.1 -shared -L/usr/lib -fPIC -o $@.so $? \
|
|
+ $(CXX) -shared -fPIC -o $@.so $? \
|
|
&& ar rvus $@.a $? \
|
|
|
|
$(GRAPHICS)/%.o: $(GRAPHICS)/%.cpp
|
|
- g++-4.1 $(CFLAGS) -c -o $@ $<
|
|
+ $(CXX) ${CXXFLAGS} -c -o $@ $<
|
|
$(UTIL)/%.o: $(UTIL)/%.cpp
|
|
- g++-4.1 $(CFLAGS) -c -o $@ $<
|
|
+ $(CXX) ${CXXFLAGS} -c -o $@ $<
|
|
$(MATH)/%.o: $(MATH)/%.cpp
|
|
- g++-4.1 $(CFLAGS) -c -o $@ $<
|
|
+ $(CXX) ${CXXFLAGS} -c -o $@ $<
|
|
|
|
.PHONY: install
|
|
install:
|