- add stage support - use @sample macro Changes: Mon Dec 23rd 2013 - Bug fix from Colin Stolley. Writing past end of a buffer. Fri May 24th 2013 - Steve Rader (the author) died. We miss him. http://www.news.wisc.edu/21829 From README: Currently, cnagios is not being actively maintained. We continue to accept simple patches from the community. PR: ports/189198 Submitted by: ohauer Approved by: Alexander <alexander.4mail@gmail.com> (maintainer)
47 lines
1.9 KiB
Text
47 lines
1.9 KiB
Text
--- ./Makefile.in.orig 2013-03-28 22:35:00.000000000 +0100
|
|
+++ ./Makefile.in 2014-05-01 14:23:32.000000000 +0200
|
|
@@ -27,39 +27,11 @@
|
|
|
|
|
|
install:
|
|
- @if [ -f @prefix@/bin/cnagios ]; then \
|
|
- echo mv @prefix@/bin/cnagios @prefix@/bin/cnagios.OLD ; \
|
|
- mv @prefix@/bin/cnagios @prefix@/bin/cnagios.OLD ; \
|
|
- fi
|
|
- @echo installing cnagios in @prefix@/bin
|
|
- @$(INSTALL) -c -m 755 cnagios @prefix@/bin/cnagios
|
|
-
|
|
- @echo installing cnagios.1 in @prefix@/man/man1
|
|
- @$(INSTALL) -c -m 755 cnagios.1 @prefix@/man/man1/cnagios.1
|
|
-
|
|
- @if [ ! -f @NAGIOS_ETC_DIR@/cnagiosrc ]; then \
|
|
- echo installing cnagiosrc in @NAGIOS_ETC_DIR@ ; \
|
|
- $(INSTALL) -c -m 644 cnagiosrc @NAGIOS_ETC_DIR@/cnagiosrc ; \
|
|
- else \
|
|
- echo installing cnagiosrc as @NAGIOS_ETC_DIR@/cnagiosrc.NEW ; \
|
|
- $(INSTALL) -c -m 644 cnagiosrc @NAGIOS_ETC_DIR@/cnagiosrc.NEW ; \
|
|
- fi
|
|
-
|
|
- @if [ ! -f @NAGIOS_ETC_DIR@/cnagios.help ]; then \
|
|
- echo installing cnagios.help in @NAGIOS_ETC_DIR@ ; \
|
|
- $(INSTALL) -c -m 644 cnagios.help @NAGIOS_ETC_DIR@/cnagios.help ; \
|
|
- else \
|
|
- echo installing cnagios.help as @NAGIOS_ETC_DIR@/cnagios.help.NEW ; \
|
|
- $(INSTALL) -c -m 644 cnagios.help @NAGIOS_ETC_DIR@/cnagios.help.NEW ; \
|
|
- fi
|
|
-
|
|
- @if [ ! -f @NAGIOS_ETC_DIR@/cnagios.pl ]; then \
|
|
- echo installing cnagios.pl in @NAGIOS_ETC_DIR@ ; \
|
|
- $(INSTALL) -c -m 644 cnagios.pl @NAGIOS_ETC_DIR@/cnagios.pl ; \
|
|
- else \
|
|
- echo installing cnagios.pl as @NAGIOS_ETC_DIR@/cnagios.pl.NEW ; \
|
|
- $(INSTALL) -c -m 644 cnagios.pl @NAGIOS_ETC_DIR@/cnagios.pl.NEW ; \
|
|
- fi
|
|
+ $(INSTALL) -c -m 755 cnagios $(DESTDIR)@prefix@/bin/cnagios
|
|
+ $(INSTALL) -c -m 444 cnagios.1 $(DESTDIR)@prefix@/man/man1/cnagios.1
|
|
+ $(INSTALL) -c -m 644 cnagiosrc $(DESTDIR)@NAGIOS_ETC_DIR@/cnagiosrc.sample
|
|
+ $(INSTALL) -c -m 644 cnagios.help $(DESTDIR)@NAGIOS_ETC_DIR@/cnagios.help.sample
|
|
+ $(INSTALL) -c -m 644 cnagios.pl $(DESTDIR)@NAGIOS_ETC_DIR@/cnagios.pl.sample
|
|
|
|
install2:
|
|
@if [ -f /usr/local/bin/cnagios ]; then \
|