375cb28253
- Removed BROKEN line - Removed CONFLICTS - binaries were renamed in this release, so no problem - Set new SWIPLDIR variable to use in pkg-plist and Makefile, that contains the new directory name that swi-pl now using. - Undefined HAVE_EXECINFO too in src/config.h to let it build successfuly - Adjusted local patches to new version (not tested on "alpha" for sure :)) - Removed files/patch-configure to make --without-jpl in CONFIGURE_ARGS actually work PR: ports/161414 Submitted by: Ruslan Mahmatkhanov <cvs-src@yandex.ru> Approved by: g.gonter@ieee.org (maintainer; timeout - 2+ weeks)
13 lines
426 B
Text
13 lines
426 B
Text
--- src/configure.orig 2011-08-18 16:46:48.000000000 +0400
|
|
+++ src/configure 2011-10-08 20:39:54.000000000 +0400
|
|
@@ -4650,8 +4650,8 @@
|
|
|
|
if test "x$custom_flags" = "xyes" ; then
|
|
if test "$GCC" = "yes"; then
|
|
- COFLAGS="${COFLAGS--O2 -fno-strict-aliasing}"
|
|
- LDFLAGS="${LDFLAGS--O2}"
|
|
+ COFLAGS="${COFLAGS--O -fno-strict-aliasing}"
|
|
+ LDFLAGS="${LDFLAGS--O}"
|
|
CWFLAGS="${CWFLAGS--Wall}"
|
|
else
|
|
COFLAGS="${COFLAGS--O}"
|