freebsd-ports/security/php73-sodium/files/patch-config.m4
Torsten Zuehlsdorff 3a5533b48d Add PHP 7.3 RC2 to the ports-tree.
Notable changes:
- Switch from PCRE to PCRE2
- Many modules now require PCRE2 for building
- graphics/php73-gd: X11 option is no longer default

Changes to Mk/Uses/php.mk approved by ale
2018-10-08 08:52:51 +00:00

17 lines
488 B
Text

--- config.m4.orig 2017-11-03 18:32:08 UTC
+++ config.m4
@@ -50,14 +50,6 @@ if test "$PHP_SODIUM" != "no"; then
PHP_ADD_LIBRARY_WITH_PATH($LIBNAME, $LIBSODIUM_DIR/$PHP_LIBDIR, SODIUM_SHARED_LIBADD)
fi
- PHP_CHECK_LIBRARY($LIBNAME,$LIBSYMBOL,
- [
- AC_DEFINE(HAVE_LIBSODIUMLIB,1,[ ])
- ],[
- AC_MSG_ERROR([wrong libsodium lib version (< 1.0.8) or lib not found])
- ],[
- ])
-
PHP_SUBST(SODIUM_SHARED_LIBADD)
PHP_NEW_EXTENSION(sodium, libsodium.c, $ext_shared)