freebsd-ports/games/xdesktopwaves/files/patch-makefile
Danilo Egea Gondolfo 3bc0b4e271 - Add stage support
2013-11-13 02:31:18 +00:00

39 lines
1.1 KiB
Text

--- ./Makefile.orig 2004-12-18 03:47:40.000000000 -0200
+++ ./Makefile 2013-11-13 00:35:29.000000000 -0200
@@ -11,19 +11,19 @@
#=========================== C compiler configuration ==========================
-CC = gcc
-CFLAGS = -I/usr/X11R6/include -O2
+#CC = gcc
+CFLAGS += -I$(LOCALBASE)/include
#============================= Linker configuration ============================
-LINK = gcc
-LFLAGS = -L/usr/X11R6/lib
+LINK = $(CC)
+LFLAGS = -L$(LOCALBASE)/lib
LIBS = -lm -lX11 -lXext
#============================ Installer configuration ==========================
-BINDIR = /usr/X11R6/bin
-MAN1DIR = /usr/X11R6/man/man1
+BINDIR = $(LOCALBASE)/bin
+MAN1DIR = $(LOCALBASE)/man/man1
INSTALL = install
RM = rm -f -v
@@ -41,8 +41,8 @@
$(RM) xdesktopwaves.o
install: xdesktopwaves xdesktopwaves.1
- $(INSTALL) -c -m 0755 -s xdesktopwaves $(BINDIR)/xdesktopwaves
- $(INSTALL) -c -m 0444 xdesktopwaves.1 $(MAN1DIR)/xdesktopwaves.1
+ $(INSTALL) -c -m 0755 -s xdesktopwaves ${DESTDIR}$(BINDIR)/xdesktopwaves
+ $(INSTALL) -c -m 0444 xdesktopwaves.1 ${DESTDIR}$(MAN1DIR)/xdesktopwaves.1
uninstall:
$(RM) $(BINDIR)/xdesktopwaves