freebsd-ports/net/etherboot/files/patch-aa
2004-06-30 21:52:50 +00:00

42 lines
1.3 KiB
Text

--- Config.orig Sun Feb 22 17:26:09 2004
+++ Config Mon Jun 21 08:23:55 2004
@@ -300,7 +300,7 @@
# Download files via TFTP
CFLAGS+= -DDOWNLOAD_PROTO_TFTP
# Change download protocol to NFS, default is TFTP
-# CFLAGS+= -DDOWNLOAD_PROTO_NFS
+CFLAGS+= -DDOWNLOAD_PROTO_NFS
# Multicast Support
# CFLAGS+=-DALLMULTI -DMULTICAST_LEVEL1 -DMULTICAST_LEVEL2 -DDOWNLOAD_PROTO_TFTM
--- arch/i386/prefix/boot1a.s.orig Sat Jun 23 10:56:25 2001
+++ arch/i386/prefix/boot1a.s Mon Mar 11 09:06:00 2002
@@ -56,7 +56,7 @@
# Partition Constants
.set PRT_OFF,0x1be # Partition offset
.set PRT_NUM,0x4 # Partitions
- .set PRT_BSD,0x1 # Partition type
+ .set PRT_BSD,0xA5 # Partition type
# Flag Bits
.set FL_PACKET,0x80 # Packet mode
@@ -398,7 +398,7 @@
.byte 0x00 # start head
.byte 0x01 # start sector (6 bits) + start cyl (2 bit)
.byte 0x00 # start cyl (low 8 bits)
- .byte 0x1 # part.type
+ .byte PRT_BSD # part.type
.byte 0xff # end head
.byte 0xff # end sect (6) + end_cyl(2)
.byte 0xff # end cyl
--- arch/i386/Makefile.orig Sun Feb 22 17:26:09 2004
+++ arch/i386/Makefile Mon Jun 21 08:35:05 2004
@@ -84,7 +84,7 @@
include $(BIN)/Roms
-allroms: $(BUILD_ROMS)
+allroms: $(BUILD_ROMS) $(DISKLOADER)
allelfs: $(BUILD_ELFS)
allpxes: $(BUILD_PXES)
allcoms: $(BUILD_COMS)