freebsd-ports/print/ghostscript7/files/patch-src-Makefile.in
Hiroki Sato 045633a1b8 Resurrect print/ghostscript7*. Ghostscript 7.x is incompatible with 8.x
and 9.x in terms of CJK character support and they are still in demand.
While I am here, the following changes have been added:

- Add LICENSE.
- Use OPTIONS_DEFINE for ghostscript drivers.
- Add MAKE_JOBS_SAFE=yes.

Discussed with:	bapt
2013-04-29 20:12:16 +00:00

96 lines
2.6 KiB
Text

--- src/Makefile.in.orig 2003-04-30 03:33:31.000000000 +0900
+++ src/Makefile.in 2008-06-21 02:23:18.000000000 +0900
@@ -50,8 +50,8 @@
# initialization files (gs_*.ps) and the fonts.
INSTALL = $(GLSRCDIR)/instcopy -c
-INSTALL_PROGRAM = $(INSTALL) -m 755
-INSTALL_DATA = $(INSTALL) -m 644
+INSTALL_PROGRAM = ${BSD_INSTALL_SCRIPT}
+INSTALL_DATA = ${BSD_INSTALL_DATA}
prefix = @prefix@
exec_prefix = @exec_prefix@
@@ -142,7 +142,7 @@
# some older JPEG streams that violate the standard. If the JPEG
# library built from local sources, the patch will be applied.
-SHARE_JPEG=@SHARE_LIBJPEG@
+SHARE_JPEG=1
JPEG_NAME=jpeg
# Define the directory where the PNG library sources are stored,
@@ -150,14 +150,14 @@
# You may need to change this if the libpng version changes.
# See libpng.mak for more information.
-SHARE_LIBPNG=@SHARE_LIBPNG@
+SHARE_LIBPNG=1
PSRCDIR=@LIBPNGDIR@
LIBPNG_NAME=png
# Define the directory where the zlib sources are stored.
# See zlib.mak for more information.
-SHARE_ZLIB=@SHARE_ZLIB@
+SHARE_ZLIB=1
ZSRCDIR=@ZLIBDIR@
#ZLIB_NAME=gz
ZLIB_NAME=z
@@ -197,12 +197,12 @@
CCLD=$(CC)
# Define the general cc flags, warnings and such.
-GCFLAGS=@GCFLAGS@
+GCFLAGS=@CPPFLAGS@ @GCFLAGS@ @CFLAGS@
# Define the added flags for standard, debugging, profiling
# and shared object builds.
-CFLAGS_STANDARD=@OPT_CFLAGS@
+CFLAGS_STANDARD?=@OPT_CFLAGS@
CFLAGS_DEBUG=-g -O
CFLAGS_PROFILE=-pg @OPT_CFLAGS@
CFLAGS_SO=-fPIC
@@ -218,7 +218,7 @@
# We don't include -ansi, because this gets in the way of the platform-
# specific stuff that <math.h> typically needs; nevertheless, we expect
# gcc to accept ANSI-style function prototypes and function definitions.
-XCFLAGS=
+XCFLAGS?=
# defines from autoconf; note that we don't use these at present.
ACDEFS=@DEFS@
@@ -232,9 +232,9 @@
# -R /usr/local/xxx/lib:/usr/local/lib
# giving the full path names of the shared library directories.
# XLDFLAGS can be set from the command line.
-XLDFLAGS=
-LDFLAGS=$(XLDFLAGS)
+LDFLAGS=@LDFLAGS@
+XLDFLAGS=$(LDFLAGS)
# Define any extra libraries to link into the executable.
# ISC Unix 2.2 wants -linet.
@@ -302,10 +302,10 @@
# If POSIX sync primitives are used, also change the STDLIBS to include
# the pthread library.
-#SYNC=posync
+SYNC=posync
# Default is No sync primitives since some platforms don't have it (HP-UX)
-SYNC=nosync
+#SYNC=nosync
# programs we use
RM=rm -f
@@ -410,6 +410,7 @@
# ---------------- End of platform-specific section ---------------- #
+include $(GLSRCDIR)/drivers.mak
include $(GLSRCDIR)/unixhead.mak
include $(GLSRCDIR)/gs.mak
include $(GLSRCDIR)/lib.mak