freebsd-ports/www/tidy-devel/files/patch-build_gmake_Makefile
Pav Lucistnik 8b337ae5f5 - Toss in -fPIC, upcoming pecl-tidy wants to link this
Approved by:	thierry (maintainer)
2006-03-22 09:06:44 +00:00

33 lines
984 B
Text

--- build/gmake/Makefile.orig Thu Jul 14 08:58:05 2005
+++ build/gmake/Makefile Thu Jul 14 22:57:37 2005
@@ -58,8 +58,8 @@
PROJECT=tidy
# Installation variables. Spaces OK, only dir create and file copy operations.
-runinst_prefix=/usr/local
-devinst_prefix=/usr/local
+runinst_prefix=${PREFIX}
+devinst_prefix=${PREFIX}
bininst = ${runinst_prefix}/bin
libinst = ${devinst_prefix}/lib
@@ -67,7 +67,7 @@
maninst = ${devinst_prefix}/man
# Internal variables. - No spaces allowed: libtool chokes on spaces in directory names.
-TOPDIR = ../..
+TOPDIR = .
INCDIR = ${TOPDIR}/include
APPDIR = ${TOPDIR}/console
SRCDIR = ${TOPDIR}/src
@@ -79,8 +79,8 @@
# CFLAGS etc..
# For optimised builds, flags such as "-O2" should be added and -D_DEBUG=1
# disabled.
-CC= gcc
-CFLAGS= -g -Wall -Wno-switch -Wno-parentheses -I $(INCDIR)
+#CC= gcc
+CFLAGS+= -g -Wall -Wno-switch -Wno-parentheses -I $(INCDIR) -fPIC
# flags only supported with gcc 3.x
# CFLAGS += -Wunused-parameter