freebsd-ports/emulators/qemu-devel/files/patch-libmath2
Juergen Lock 54b840b37a - Update to 20080620 svn snapshot, which uses the new kqemu-kmod-devel
port that now also works for the 32 bit "qemu" executable on amd64
  (if you build with the KQEMU knob on, you have to deinstall the old
  kqemu-kmod first if it is installed)
- Add an ALL_TARGETS knob that, if turned off, omits the remaining dyngen
  targets, eliminating the need for gcc 3.4 (everything but ppc and sh4
  has been converted to tcg in this snapshot)
- Add tcg fixes for amd64 guests on i386 hosts (two of three have been
  committed to qemu svn in the meantime) [1]
- Update the pkg-message about kqemu on amd64, and add a note about using
  nfs with slirp, the latter [2]
- Homepage now at http://bellard.org/qemu/ - update links

Submitted by:	nox [1]
Submitted by:	joerg [2]
2008-07-08 18:42:09 +00:00

57 lines
1.1 KiB
Text

Index: qemu/bsd/Makefile
@@ -16,7 +16,8 @@
${MACHINE_ARCH}/s_rintl.c \
${MACHINE_ARCH}/s_round.c \
${MACHINE_ARCH}/s_sinl.S \
- ${MACHINE_ARCH}/s_tanl.S
+ ${MACHINE_ARCH}/s_tanl.S \
+ ${MACHINE_ARCH}/s_ldexpl.c
OBJS= ${SRCS:R:S/$/.o/}
Index: qemu/bsd/i386/s_ldexpl.c
@@ -0,0 +1,21 @@
+#include <math.h>
+#include <errno.h>
+#include <sysdep.h>
+
+long double __ldexpl(long double x, int expn)
+{
+ long double res;
+ if (!isfinite (x) || x == 0.0L)
+ return x;
+
+ __asm__ ("fscale"
+ : "=t" (res)
+ : "0" (x), "u" ((long double) expn));
+
+ if (!isfinite (res) || res == 0.0L)
+ errno = ERANGE;
+
+ return res;
+}
+
+weak_alias(__ldexpl,ldexpl)
Index: qemu/bsd/amd64/s_ldexpl.c
@@ -0,0 +1,21 @@
+#include <math.h>
+#include <errno.h>
+#include <sysdep.h>
+
+long double __ldexpl(long double x, int expn)
+{
+ long double res;
+ if (!isfinite (x) || x == 0.0L)
+ return x;
+
+ __asm__ ("fscale"
+ : "=t" (res)
+ : "0" (x), "u" ((long double) expn));
+
+ if (!isfinite (res) || res == 0.0L)
+ errno = ERANGE;
+
+ return res;
+}
+
+weak_alias(__ldexpl,ldexpl)