PR: ports/115954 Submitted by: Nikos Ntarmos <ntarmos at ceid.upatras.gr> Reworked by: mm Approved by: maintainer timeout
18 lines
492 B
Text
18 lines
492 B
Text
--- fuse_module/Makefile.orig 2007-06-19 14:35:22.000000000 +0200
|
|
+++ fuse_module/Makefile 2007-08-16 18:31:50.000000000 +0200
|
|
@@ -21,7 +21,14 @@
|
|
.endif
|
|
|
|
.if defined(KERNCONF)
|
|
-KERNCONFDIR= /usr/obj/usr/src/sys/${KERNCONF}
|
|
+.if !defined(MAKEOBJDIRPREFIX)
|
|
+MAKEOBJDIRPREFIX=/usr/obj
|
|
+.endif
|
|
+.if !defined(SRC_BASE)
|
|
+SRC_BASE=/usr/src
|
|
+.endif
|
|
+KERNCONF1!= echo ${KERNCONF} | sed -e 's/ .*//g'
|
|
+KERNCONFDIR= ${MAKEOBJDIRPREFIX}${SRC_BASE}/sys/${KERNCONF1}
|
|
.endif
|
|
|
|
.if defined(KERNCONFDIR)
|