freebsd-ports/security/pam_abl/files/patch-tools-Makefile
Pav Lucistnik bf663cc26b The pam_abl provides auto blacklisting of hosts and users
responsible for repeated failed authentication attempts.

WWW: http://www.hexten.net/pam_abl/

PR:		ports/100635
Submitted by:	Petr Rehor <prehor@gmail.com>
2006-09-01 18:34:03 +00:00

26 lines
575 B
Text

--- tools/Makefile.orig Wed Oct 12 21:22:27 2005
+++ tools/Makefile Sun Dec 11 00:22:30 2005
@@ -1,18 +1,18 @@
# Makefile
-CFLAGS=-Wall
-LIBS=-ldb -lpthread
+CFLAGS=-Wall -I/usr/local/include
+LIBS=-L/usr/local/lib -ldb -lpthread
TARGET=pam_abl
OBJ=log.o config.o rule.o pam_abl.o
-INSTDIR=/usr/bin
+INSTDIR=%%PREFIX%%/sbin
all : $(TARGET)
$(TARGET) : $(OBJ)
- cc $(LIBS) -o $@ $^
+ cc $(LIBS) -o $(TARGET) $(OBJ)
install : $(TARGET)
- install --mode=755 --strip $(TARGET) $(INSTDIR)
+ install -m 755 -s $(TARGET) $(INSTDIR)
clean :
rm -f $(TARGET) $(OBJ)