0bd48c5d88
ntp links against gettext (libintl) if it is installed on the system: - Add an NLS OPTION to explicitly enable, disable and track libintl dependency - Add DEBUG and THREADS OPTIONS. Keep the latter enabled by OPTIONS_DEFAULT to preserve compatibility with existing behaviour. - Explicitly pass OpenSSL include / library dir paths to configure - Unsilence install command - Enable verbose building (--disable-silent-rules) - Use TOUCH variable instead of hardcoded command - Add TEST_TARGET to enable test suite - Patch sntp tests to ensure they link correctly to threading library - Pet portlint (*_DEPENDS order, group USE{S} sections, sort OPTIONS) Approved by: cy (maintainer) Differential Revision: D4812 MFH: 2016Q1
10 lines
249 B
Text
10 lines
249 B
Text
--- sntp/tests/Makefile.in.orig 2015-10-27 12:47:07 UTC
|
|
+++ sntp/tests/Makefile.in
|
|
@@ -791,6 +791,7 @@ LDADD = \
|
|
$(base_LDADD) \
|
|
$(top_builddir)/unity/libunity.a \
|
|
$(LIBM) \
|
|
+ $(PTHREAD_LIBS) \
|
|
$(NULL)
|
|
|
|
AM_CFLAGS = $(CFLAGS_NTP)
|