freebsd-ports/net-mgmt/adcli/files/patch-configure
Mikhail Teterin d30374f60a net-mgmt/adcli: Upgrade to 0.9.1, fix generation of documentation.
The older version (0.8.x) cannot deal with newer ADs.

Requested by: University of California in Santa Cruz.
2021-10-20 14:46:46 -04:00

24 lines
745 B
Text

--- configure.ac 2021-02-20 08:51:40.000000000 -0500
+++ configure.ac 2021-10-12 16:57:31.442711000 -0400
@@ -104,5 +104,8 @@
LIBS="$LIBS $lib"
AC_LINK_IFELSE([
- AC_LANG_PROGRAM([#include <resolv.h>],
+ AC_LANG_PROGRAM([[#include <sys/types.h>]
+ [#include <netinet/in.h>]
+ [#include <arpa/nameser.h>]
+ [#include <resolv.h>]],
[res_query (0, 0, 0, 0, 0)])
],
@@ -269,11 +272,4 @@
else
AC_DEFINE_UNQUOTED(BIN_CAT, "$BIN_CAT", [path to cat, used in unit test])
-fi
-
-AC_PATH_PROG(BIN_TAC, tac, no)
-if test "$BIN_TAC" = "no" ; then
- AC_MSG_ERROR([tac is not available])
-else
- AC_DEFINE_UNQUOTED(BIN_TAC, "$BIN_TAC", [path to tac, used in unit test])
fi