freebsd-ports/cad/chipmunk/files/patch-ap
Ying-Chieh Liao 797d6cd4f1 upgrade to 5.59
PR:		38227
Submitted by:	Ports Fury
2002-05-21 03:30:49 +00:00

37 lines
742 B
Text

--- util/sctomat/Makefile.orig Wed Mar 12 02:47:26 1997
+++ util/sctomat/Makefile Sat May 18 13:14:35 2002
@@ -5,7 +5,7 @@
#
# sctomat makefile
-BINDIR= ../../bin
+BINDIR= ${PREFIX}/bin
##
## (1) Choosing your compiler
@@ -32,7 +32,7 @@
##
CHIPMUNKCC = gcc
-CC = $(CHIPMUNKCC)
+CC ?= $(CHIPMUNKCC)
##
## (2) Adding appropriate flags
@@ -76,13 +76,13 @@
## -m68040 : for 68040 and 68060
##
-CFLAGS =
+CFLAGS += -DBSD -DF_OK=0
-scope_to_mat: savemat.o scope_to_mat.o
+all: savemat.o scope_to_mat.o
$(CC) savemat.o scope_to_mat.o -lm -o scope_to_mat
install: scope_to_mat
- cp scope_to_mat $(BINDIR)
+ ${BSD_INSTALL_PROGRAM} scope_to_mat $(BINDIR)
clean:
-rm -f *.o scope_to_mat