0d2725682b
structure (i.e. include/SDL for includes and sdl-config for configuration binary) - Update graphics/sdl_ttf to version 2.0.8 - Update graphics/sdl_image to version 1.2.5 - Update audio/sdl_mixer to version 1.2.7 - Update net/sdl_net to version 1.2.6 - Update Mk/bsd.sdl.mk accordingly - Fix dependent ports to fit the new directory structure and avoid several API breakages - Bump up portrevisions for all dependent ports to allow them to be upgraded by portupgrade/portmaster etc tools Approved by: kris (portmgr), sem (mentor)
14 lines
628 B
C++
14 lines
628 B
C++
--- src/sound.cpp.orig Tue Sep 12 19:39:38 2006
|
|
+++ src/sound.cpp Tue Sep 12 19:41:19 2006
|
|
@@ -282,9 +282,9 @@
|
|
alutLoadWAVFile((ALbyte*)(filename).c_str(), &format, &data, &size, &freq);
|
|
#else
|
|
#ifdef OLD_OPENAL
|
|
- alutLoadWAVFile((ALbyte*)(filename).c_str(), &format, &data, &size, &freq, &loop);
|
|
+ alutLoadWAVFile(filename.c_str(), &format, &data, &size, &freq, &loop);
|
|
#else
|
|
- data = alutLoadMemoryFromFile((ALbyte*)(filename).c_str(), &format, &size, &freq);
|
|
+ data = alutLoadMemoryFromFile(filename.c_str(), &format, &size, &freq);
|
|
#endif
|
|
#endif
|
|
//bool err = LoadWave(filename, &format, &data, &size, &freq, &loop);
|