freebsd-ports/mail/mutt-devel/files/patch-examples
Martin Wilke 2e1f858ad9 - Update to 1.5.17
PR:		117822
Submitted by:	Udo Schweigert <udo.schweigert@siemens.com> (maintainer)
		rafan (zh-mutt maintainer)
2007-12-13 01:26:10 +00:00

121 lines
4.7 KiB
Text
Raw Blame History

This file contains invisible Unicode characters

This file contains invisible Unicode characters that are indistinguishable to humans but may be processed differently by a computer. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

--- contrib/Makefile.am.orig Tue Jul 18 20:04:14 2006
+++ contrib/Makefile.am Wed Aug 30 16:05:33 2006
@@ -1,6 +1,7 @@
# $Id: Makefile.am,v 3.1 2006/07/18 18:04:14 brendan Exp $
subdir = contrib
+samplesdir = @samplesdir@
SAMPLES = Mush.rc Pine.rc gpg.rc pgp2.rc pgp5.rc pgp6.rc Tin.rc \
sample.muttrc sample.mailcap sample.muttrc-tlr \
@@ -14,12 +15,12 @@
iconv/make.sh
install-data-local:
- $(top_srcdir)/mkinstalldirs $(DESTDIR)$(docdir)/samples $(DESTDIR)$(docdir)/samples/iconv
+ $(top_srcdir)/mkinstalldirs $(DESTDIR)$(samplesdir) $(DESTDIR)$(samplesdir)/iconv
for f in $(SAMPLES) ; do \
- $(INSTALL) -m 644 $(srcdir)/$$f $(DESTDIR)$(docdir)/samples ; \
+ $(INSTALL) -m 644 $(srcdir)/$$f $(DESTDIR)$(samplesdir) ; \
done
for f in $(srcdir)/iconv/*.rc ; do \
- $(INSTALL) -m 644 $$f $(DESTDIR)$(docdir)/samples/iconv ; \
+ $(INSTALL) -m 644 $$f $(DESTDIR)$(samplesdir)/iconv ; \
done
uninstall-local:
--- init.h.orig Tue Mar 4 10:28:12 2003
+++ init.h Wed Mar 26 15:41:19 2003
@@ -1455,8 +1455,8 @@
** .pp
** For examples on how to configure these formats for the various versions
** of PGP which are floating around, see the pgp*.rc and gpg.rc files in
- ** the samples/ subdirectory which has been installed on your system
- ** alongside the documentation.
+ ** the share/examples/mutt subdirectory which has been installed on your
+ ** system.
** (PGP only)
*/
{ "pgp_getkeys_command", DT_STR, R_NONE, UL &PgpGetkeysCommand, 0},
@@ -1628,8 +1628,8 @@
** .de
** .pp
** For examples on how to configure these formats, see the smime.rc in
- ** the samples/ subdirectory which has been installed on your system
- ** alongside the documentation.
+ ** the share/examples/mutt subdirectory which has been installed on your
+ ** system.
** (S/MIME only)
*/
{ "smime_verify_command", DT_STR, R_NONE, UL &SmimeVerifyCommand, 0},
--- Makefile.am.orig Mon Apr 9 15:21:50 2007
+++ Makefile.am Mon Apr 9 15:24:06 2007
@@ -13,7 +13,7 @@
bin_SCRIPTS = muttbug flea @SMIMEAUX_TARGET@
-BUILT_SOURCES = keymap_defs.h patchlist.c reldate.h hcversion.h
+BUILT_SOURCES = keymap_defs.h patchlist.c reldate.h hcversion.h Muttrc
bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
mutt_SOURCES = $(BUILT_SOURCES) \
--- INSTALL.orig Mon Nov 25 15:16:46 2002
+++ INSTALL Wed Mar 26 15:59:57 2003
@@ -225,13 +225,13 @@
need to tell mutt about implementation-defined names for some
character sets. Sample configuration files for various systems can
be found in the directory contrib/iconv/ in this source
-distribution, and will be installed in the samples/iconv directory
+distribution, and will be installed in the share/examples/mutt/iconv directory
as part of mutt's documentation.
In order to use these sample configuration files, just put a line
like
- source /usr/local/doc/mutt/samples/iconv/iconv.osf1-4.0d.rc
+ source /usr/local/share/examples/mutt/iconv/iconv.osf1-4.0d.rc
into your system's global Muttrc, which normally resides in /etc or
/usr/local/etc.
--- doc/manual.txt.orig Thu Nov 1 22:07:09 2007
+++ doc/manual.txt Sun Nov 4 13:55:21 2007
@@ -2617,9 +2617,10 @@
shows that arguments can be quoted: the script will receive the expanded string
between the single quotes as the only argument.
-A practical example is the mutt_xtitle script installed in the samples
-subdirectory of the mutt documentation: it can be used as filter for
-$status_format to set the current terminal's title, if supported.
+A practical example is the mutt_xtitle script installed in the
+share/examples/mutt/ subdirectory of the mutt documentation: it can be used as
+filter for $status_format to set the current terminal's title, if supported.
+
Chapter 4. Advanced Usage
@@ -6957,9 +6958,9 @@
One or more key IDs.
For examples on how to configure these formats for the various versions of PGP
-which are floating around, see the pgp*.rc and gpg.rc files in the samples/
-subdirectory which has been installed on your system alongside the
-documentation. (PGP only)
+which are floating around, see the pgp*.rc and gpg.rc files in the
+share/examples/mutt/ subdirectory which has been installed on your system
+alongside the documentation. (PGP only)
3.169. pgp_getkeys_command
@@ -7155,9 +7156,9 @@
or file, this expands to "-CApath $smime_ca_location" or "-CAfile
$smime_ca_location".
-For examples on how to configure these formats, see the smime.rc in the samples
-/ subdirectory which has been installed on your system alongside the
-documentation. (S/MIME only)
+For examples on how to configure these formats, see the smime.rc in the
+share/examples/mutt/ subdirectory which has been installed on your system
+alongside the documentation. (S/MIME only)
3.188. smime_verify_command