freebsd-ports/emulators/yuzu/files/patch-CMakeLists.txt
Jan Beich f3cea852d5 emulators/yuzu: update to s20200628
Compared to r540846
- Avoid crashes using slightly older version
- System libzip to allow OpenSSL 1.0
- Drop bundled cryptopp unused since r459140

Changes:	50c27d5ae...8596a1277
2020-07-01 12:42:19 +00:00

15 lines
531 B
Text

yuzu (Qt) currently needs SDL for input
--- CMakeLists.txt.orig 2020-06-29 05:12:38 UTC
+++ CMakeLists.txt
@@ -225,7 +225,9 @@ if(ENABLE_SDL2)
list(APPEND CMAKE_MODULE_PATH "${CONAN_SDL2_ROOT_RELEASE}")
list(APPEND CMAKE_PREFIX_PATH "${CONAN_SDL2_ROOT_RELEASE}")
endif()
- find_package(SDL2)
+endif()
+find_package(SDL2)
+if(ENABLE_SDL2)
if (NOT SDL2_FOUND)
# otherwise add this to the list of libraries to install
list(APPEND CONAN_REQUIRED_LIBS "sdl2/2.0.12@bincrafters/stable")