00447b74b9
- Tidy most of the port's files: pkg-plist, pkg-message, Makefile, etc. - The port conforms a little more to FreeBSD Porter's Handbook (always evolving...) - Validate a complete recommended test ordering from porting-testing.html (In fact, correct it to do so.) While I'm here: move "@unexec if cmp -s %D/etc/nb.conf.sample..." upwards at pkg-plist (before %D/etc/nb.conf.sample). PR: 107963 Submitted by: Julien Gabel <julien.gabel at thilelli.net> (maintainer)
23 lines
660 B
Text
23 lines
660 B
Text
--- nb.orig Sun Jan 14 17:38:03 2007
|
|
+++ nb Sun Jan 14 17:41:26 2007
|
|
@@ -1,4 +1,4 @@
|
|
-#! /bin/bash
|
|
+#!/usr/bin/env bash
|
|
############################################################
|
|
# NanoBlogger 3.3 Copyright 2006 n1xt3r (Kevin R. Wood) #
|
|
############################################################
|
|
@@ -8,11 +8,11 @@
|
|
VERSION="3.3"
|
|
|
|
# nanoblogger's base install directory.
|
|
-NB_BASE_DIR=`dirname $0`
|
|
+NB_BASE_DIR="%%PREFIX%%/share/nanoblogger"
|
|
# documentation
|
|
-NB_DOC_DIR="$NB_BASE_DIR/docs"
|
|
+NB_DOC_DIR="%%PREFIX%%/share/doc/nanoblogger"
|
|
# nanoblogger's conf file
|
|
-NB_CFG_DIR="$NB_BASE_DIR"
|
|
+NB_CFG_DIR="%%PREFIX%%/etc"
|
|
|
|
### hardcoded paths ###
|
|
|