freebsd-ports/devel/pwlib/files/patch-src-ptlib-unix-udll.cxx
Pav Lucistnik 9b586f478b - Use a better way to detect SDL header
- Add WITH_ESOUND knob and enable the plugin build
- Fix bsdvideo (bktr(4)) plugin and make it buildable on more archs
- Add a small error handler to detect unresolved symbols in plugins
- Add more plugins to pkg-plist
- Add experimental support for firewire(4) based video devices.
  The segment of the Makefile is intentionally commented out.

PR:		ports/95422, ports/96624
Submitted by:	Joerg Pulz <Joerg.Pulz@frm2.tum.de>,
		Steve Ames <steve@energistic.com> (maintainer)
Approved by:	Steve Ames <steve@energistic.com> (maintainer)
2006-05-07 13:02:10 +00:00

13 lines
400 B
C++

--- src/ptlib/unix/udll.cxx.orig Wed Nov 30 13:47:42 2005
+++ src/ptlib/unix/udll.cxx Wed Apr 5 22:36:51 2006
@@ -382,6 +382,10 @@
dllHandle = dlopen((char *)(const char *)name, RTLD_NOW);
#else
+ const char *dummyerr = dlerror();
dllHandle = dlopen((const char *)name, RTLD_NOW);
+ const char *err = dlerror();
+ if (err != NULL)
+ cerr << err << '\n';
#endif
return IsLoaded();