freebsd-ports/x11-wm/windowmaker/files/patch-WINGs__Makefile.in
Hiroki Sato 66732e092d Update to 0.95.7. Changes include:
- Window snapping (maximize a window to a side or corder of the screen) by
  dragging is now supported.

- It is now possible to customize behavior when a maximized window is
  dragged.

- A knob is added to globally ignore decoration hints from GNOME
  appications.

- A ICCCM protocol for window manager replacement has been supported.
2015-10-06 05:12:56 +00:00

33 lines
1.5 KiB
Text

--- WINGs/Makefile.in.orig 2015-10-06 04:12:10 UTC
+++ WINGs/Makefile.in
@@ -135,8 +135,7 @@ am__uninstall_files_from_dir = { \
am__installdirs = "$(DESTDIR)$(libdir)" "$(DESTDIR)$(bindir)" \
"$(DESTDIR)$(pkgconfigdir)"
LTLIBRARIES = $(lib_LTLIBRARIES)
-libWINGs_la_DEPENDENCIES = libWUtil.la \
- $(top_builddir)/wrlib/libwraster.la
+libWINGs_la_DEPENDENCIES = libWUtil.la
am_libWINGs_la_OBJECTS = configuration.lo dragcommon.lo \
dragdestination.lo dragsource.lo selection.lo wappresource.lo \
wballoon.lo wbox.lo wbrowser.lo wbutton.lo wcolor.lo \
@@ -438,8 +437,8 @@ libWINGs_la_LDFLAGS = -version-info @WIN
libWUtil_la_LDFLAGS = -version-info @WUTIL_VERSION@
dist_bin_SCRIPTS = get-wings-flags get-wutil-flags
lib_LTLIBRARIES = libWUtil.la libWINGs.la
-LDADD = libWUtil.la libWINGs.la $(top_builddir)/wrlib/libwraster.la @INTLIBS@
-libWINGs_la_LIBADD = libWUtil.la $(top_builddir)/wrlib/libwraster.la @XLIBS@ @XFTLIBS@ @FCLIBS@ @LIBM@ @PANGOLIBS@
+LDADD = libWUtil.la libWINGs.la -lwraster @INTLIBS@
+libWINGs_la_LIBADD = libWUtil.la -lwraster @XLIBS@ @XFTLIBS@ @FCLIBS@ @LIBM@ @PANGOLIBS@
libWUtil_la_LIBADD = @LIBBSD@
EXTRA_DIST = BUGS make-rgb Examples Extras Tests
@@ -513,7 +512,8 @@ libWUtil_la_SOURCES = \
AM_CFLAGS =
AM_CPPFLAGS = -DRESOURCE_PATH=\"$(datadir)/WINGs\" \
- -I$(top_srcdir)/WINGs/WINGs -I$(top_srcdir)/wrlib -I$(top_srcdir)/src \
+ -DPREFIX=\"$(prefix)\" \
+ -I$(top_srcdir)/WINGs/WINGs -I$(top_srcdir)/src \
@XFTFLAGS@ @HEADER_SEARCH_PATH@
pkgconfigdir = $(prefix)/libdata/pkgconfig