freebsd-ports/net/py-port-for/files/patch-setup.py
Kubilay Kocak dd27ccb2f1 net/py-port-for: Update to 0.3.1
- Update PORTVERSION and distinfo checksum (0.3.1)
- Add TEST_DEPENDS and test target
- Add LICENSE_FILE
- Update COMMENT (matching setup.py:description)
- Enable NO_ARCH (architecture independent)
- Patch setup.py adding tests_require and support for test command
2016-02-25 13:03:44 +00:00

22 lines
457 B
Python

--- setup.py.orig 2016-02-25 12:42:58 UTC
+++ setup.py
@@ -8,6 +8,11 @@ for cmd in ('egg_info', 'develop'):
version='0.3.1'
+tests_require = [
+ 'nose',
+ 'mock>=0.8',
+]
+
setup(
name='port-for',
version=version,
@@ -44,4 +49,7 @@ setup(
'Topic :: System :: Systems Administration',
'Topic :: Internet :: WWW/HTTP :: Site Management',
],
+
+ tests_require=tests_require,
+ test_suite='nose.collector',
)