- Add devel/libsysinfo to LIB_DEPENDS - Add x11/xmessage to RUN_DEPENDS - Add netstatus, volumeasla, thermal, cpu, cpufreq, monitors and wnckpager plugins to CONFIGURE_ARGS - Add cpufreq, netstatus and thermal plugin patches - Add batt plugin patch - Remove -Wno-return-type from CFLAGS - Change ALSA_RUN_DEPENDS to ALSA_LIB_DEPENDS PR: 190362 Submitted by: Horia Racoviceanu <horia@racoviceanu.com> (maintainer)
462 lines
18 KiB
Text
462 lines
18 KiB
Text
--- ./src/plugins/thermal/Makefile.in.orig 2014-05-09 09:31:26.000000000 -0400
|
|
+++ ./src/plugins/thermal/Makefile.in 2014-05-20 09:47:15.000000000 -0400
|
|
@@ -1,8 +1,9 @@
|
|
-# Makefile.in generated by automake 1.14.1 from Makefile.am.
|
|
+# Makefile.in generated by automake 1.11.1 from Makefile.am.
|
|
# @configure_input@
|
|
|
|
-# Copyright (C) 1994-2013 Free Software Foundation, Inc.
|
|
-
|
|
+# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
|
|
+# 2003, 2004, 2005, 2006, 2007, 2008, 2009 Free Software Foundation,
|
|
+# Inc.
|
|
# This Makefile.in is free software; the Free Software Foundation
|
|
# gives unlimited permission to copy and/or distribute it,
|
|
# with or without modifications, as long as this notice is preserved.
|
|
@@ -15,51 +16,6 @@
|
|
@SET_MAKE@
|
|
|
|
VPATH = @srcdir@
|
|
-am__is_gnu_make = test -n '$(MAKEFILE_LIST)' && test -n '$(MAKELEVEL)'
|
|
-am__make_running_with_option = \
|
|
- case $${target_option-} in \
|
|
- ?) ;; \
|
|
- *) echo "am__make_running_with_option: internal error: invalid" \
|
|
- "target option '$${target_option-}' specified" >&2; \
|
|
- exit 1;; \
|
|
- esac; \
|
|
- has_opt=no; \
|
|
- sane_makeflags=$$MAKEFLAGS; \
|
|
- if $(am__is_gnu_make); then \
|
|
- sane_makeflags=$$MFLAGS; \
|
|
- else \
|
|
- case $$MAKEFLAGS in \
|
|
- *\\[\ \ ]*) \
|
|
- bs=\\; \
|
|
- sane_makeflags=`printf '%s\n' "$$MAKEFLAGS" \
|
|
- | sed "s/$$bs$$bs[$$bs $$bs ]*//g"`;; \
|
|
- esac; \
|
|
- fi; \
|
|
- skip_next=no; \
|
|
- strip_trailopt () \
|
|
- { \
|
|
- flg=`printf '%s\n' "$$flg" | sed "s/$$1.*$$//"`; \
|
|
- }; \
|
|
- for flg in $$sane_makeflags; do \
|
|
- test $$skip_next = yes && { skip_next=no; continue; }; \
|
|
- case $$flg in \
|
|
- *=*|--*) continue;; \
|
|
- -*I) strip_trailopt 'I'; skip_next=yes;; \
|
|
- -*I?*) strip_trailopt 'I';; \
|
|
- -*O) strip_trailopt 'O'; skip_next=yes;; \
|
|
- -*O?*) strip_trailopt 'O';; \
|
|
- -*l) strip_trailopt 'l'; skip_next=yes;; \
|
|
- -*l?*) strip_trailopt 'l';; \
|
|
- -[dEDm]) skip_next=yes;; \
|
|
- -[JT]) skip_next=yes;; \
|
|
- esac; \
|
|
- case $$flg in \
|
|
- *$$target_option*) has_opt=yes; break;; \
|
|
- esac; \
|
|
- done; \
|
|
- test $$has_opt = yes
|
|
-am__make_dryrun = (target_option=n; $(am__make_running_with_option))
|
|
-am__make_keepgoing = (target_option=k; $(am__make_running_with_option))
|
|
pkgdatadir = $(datadir)/@PACKAGE@
|
|
pkgincludedir = $(includedir)/@PACKAGE@
|
|
pkglibdir = $(libdir)/@PACKAGE@
|
|
@@ -79,21 +35,13 @@
|
|
build_triplet = @build@
|
|
host_triplet = @host@
|
|
subdir = src/plugins/thermal
|
|
-DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/Makefile.am \
|
|
- $(top_srcdir)/mkinstalldirs $(top_srcdir)/depcomp
|
|
+DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
|
|
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
|
-am__aclocal_m4_deps = $(top_srcdir)/m4/gettext.m4 \
|
|
- $(top_srcdir)/m4/iconv.m4 $(top_srcdir)/m4/intltool.m4 \
|
|
- $(top_srcdir)/m4/lib-ld.m4 $(top_srcdir)/m4/lib-link.m4 \
|
|
- $(top_srcdir)/m4/lib-prefix.m4 $(top_srcdir)/m4/libtool.m4 \
|
|
- $(top_srcdir)/m4/ltoptions.m4 $(top_srcdir)/m4/ltsugar.m4 \
|
|
- $(top_srcdir)/m4/ltversion.m4 $(top_srcdir)/m4/lt~obsolete.m4 \
|
|
- $(top_srcdir)/m4/nls.m4 $(top_srcdir)/m4/po.m4 \
|
|
- $(top_srcdir)/m4/progtest.m4 $(top_srcdir)/acinclude.m4 \
|
|
+am__aclocal_m4_deps = $(top_srcdir)/acinclude.m4 \
|
|
$(top_srcdir)/configure.ac
|
|
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
|
|
$(ACLOCAL_M4)
|
|
-mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
|
+mkinstalldirs = $(install_sh) -d
|
|
CONFIG_HEADER = $(top_builddir)/config.h
|
|
CONFIG_CLEAN_FILES =
|
|
CONFIG_CLEAN_VPATH_FILES =
|
|
@@ -118,37 +66,18 @@
|
|
am__base_list = \
|
|
sed '$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g' | \
|
|
sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
|
|
-am__uninstall_files_from_dir = { \
|
|
- test -z "$$files" \
|
|
- || { test ! -d "$$dir" && test ! -f "$$dir" && test ! -r "$$dir"; } \
|
|
- || { echo " ( cd '$$dir' && rm -f" $$files ")"; \
|
|
- $(am__cd) "$$dir" && rm -f $$files; }; \
|
|
- }
|
|
am__installdirs = "$(DESTDIR)$(moduledir)"
|
|
LTLIBRARIES = $(module_LTLIBRARIES)
|
|
am__DEPENDENCIES_1 =
|
|
thermal_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
|
|
am_thermal_la_OBJECTS = thermal_la-thermal.lo
|
|
thermal_la_OBJECTS = $(am_thermal_la_OBJECTS)
|
|
-AM_V_lt = $(am__v_lt_@AM_V@)
|
|
-am__v_lt_ = $(am__v_lt_@AM_DEFAULT_V@)
|
|
+AM_V_lt = $(am__v_lt_$(V))
|
|
+am__v_lt_ = $(am__v_lt_$(AM_DEFAULT_VERBOSITY))
|
|
am__v_lt_0 = --silent
|
|
-am__v_lt_1 =
|
|
thermal_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
|
|
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(thermal_la_CFLAGS) \
|
|
$(CFLAGS) $(thermal_la_LDFLAGS) $(LDFLAGS) -o $@
|
|
-AM_V_P = $(am__v_P_@AM_V@)
|
|
-am__v_P_ = $(am__v_P_@AM_DEFAULT_V@)
|
|
-am__v_P_0 = false
|
|
-am__v_P_1 = :
|
|
-AM_V_GEN = $(am__v_GEN_@AM_V@)
|
|
-am__v_GEN_ = $(am__v_GEN_@AM_DEFAULT_V@)
|
|
-am__v_GEN_0 = @echo " GEN " $@;
|
|
-am__v_GEN_1 =
|
|
-AM_V_at = $(am__v_at_@AM_V@)
|
|
-am__v_at_ = $(am__v_at_@AM_DEFAULT_V@)
|
|
-am__v_at_0 = @
|
|
-am__v_at_1 =
|
|
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
|
|
depcomp = $(SHELL) $(top_srcdir)/depcomp
|
|
am__depfiles_maybe = depfiles
|
|
@@ -159,42 +88,24 @@
|
|
$(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) \
|
|
$(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
|
|
$(AM_CFLAGS) $(CFLAGS)
|
|
-AM_V_CC = $(am__v_CC_@AM_V@)
|
|
-am__v_CC_ = $(am__v_CC_@AM_DEFAULT_V@)
|
|
-am__v_CC_0 = @echo " CC " $@;
|
|
-am__v_CC_1 =
|
|
+AM_V_CC = $(am__v_CC_$(V))
|
|
+am__v_CC_ = $(am__v_CC_$(AM_DEFAULT_VERBOSITY))
|
|
+am__v_CC_0 = @echo " CC " $@;
|
|
+AM_V_at = $(am__v_at_$(V))
|
|
+am__v_at_ = $(am__v_at_$(AM_DEFAULT_VERBOSITY))
|
|
+am__v_at_0 = @
|
|
CCLD = $(CC)
|
|
LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
|
|
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
|
$(AM_LDFLAGS) $(LDFLAGS) -o $@
|
|
-AM_V_CCLD = $(am__v_CCLD_@AM_V@)
|
|
-am__v_CCLD_ = $(am__v_CCLD_@AM_DEFAULT_V@)
|
|
-am__v_CCLD_0 = @echo " CCLD " $@;
|
|
-am__v_CCLD_1 =
|
|
+AM_V_CCLD = $(am__v_CCLD_$(V))
|
|
+am__v_CCLD_ = $(am__v_CCLD_$(AM_DEFAULT_VERBOSITY))
|
|
+am__v_CCLD_0 = @echo " CCLD " $@;
|
|
+AM_V_GEN = $(am__v_GEN_$(V))
|
|
+am__v_GEN_ = $(am__v_GEN_$(AM_DEFAULT_VERBOSITY))
|
|
+am__v_GEN_0 = @echo " GEN " $@;
|
|
SOURCES = $(thermal_la_SOURCES)
|
|
DIST_SOURCES = $(thermal_la_SOURCES)
|
|
-am__can_run_installinfo = \
|
|
- case $$AM_UPDATE_INFO_DIR in \
|
|
- n|no|NO) false;; \
|
|
- *) (install-info --version) >/dev/null 2>&1;; \
|
|
- esac
|
|
-am__tagged_files = $(HEADERS) $(SOURCES) $(TAGS_FILES) $(LISP)
|
|
-# Read a list of newline-separated strings from the standard input,
|
|
-# and print each of them once, without duplicates. Input order is
|
|
-# *not* preserved.
|
|
-am__uniquify_input = $(AWK) '\
|
|
- BEGIN { nonempty = 0; } \
|
|
- { items[$$0] = 1; nonempty = 1; } \
|
|
- END { if (nonempty) { for (i in items) print i; }; } \
|
|
-'
|
|
-# Make sure the list of sources is unique. This is necessary because,
|
|
-# e.g., the same source file might be shared among _SOURCES variables
|
|
-# for different programs/libraries.
|
|
-am__define_uniq_tagged_files = \
|
|
- list='$(am__tagged_files)'; \
|
|
- unique=`for i in $$list; do \
|
|
- if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
|
|
- done | $(am__uniquify_input)`
|
|
ETAGS = etags
|
|
CTAGS = ctags
|
|
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
|
@@ -204,8 +115,6 @@
|
|
ALL_PLUGINS_LIST = @ALL_PLUGINS_LIST@
|
|
AMTAR = @AMTAR@
|
|
AM_DEFAULT_VERBOSITY = @AM_DEFAULT_VERBOSITY@
|
|
-APPLET_CFLAGS = @APPLET_CFLAGS@
|
|
-APPLET_LIBS = @APPLET_LIBS@
|
|
AR = @AR@
|
|
AUTOCONF = @AUTOCONF@
|
|
AUTOHEADER = @AUTOHEADER@
|
|
@@ -236,8 +145,6 @@
|
|
GMSGFMT = @GMSGFMT@
|
|
GREP = @GREP@
|
|
G_CAST_CHECKS = @G_CAST_CHECKS@
|
|
-INDICATORDIR = @INDICATORDIR@
|
|
-INDICATORICONSDIR = @INDICATORICONSDIR@
|
|
INSTALL = @INSTALL@
|
|
INSTALL_DATA = @INSTALL_DATA@
|
|
INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
|
@@ -249,21 +156,13 @@
|
|
INTLTOOL_MERGE = @INTLTOOL_MERGE@
|
|
INTLTOOL_PERL = @INTLTOOL_PERL@
|
|
INTLTOOL_UPDATE = @INTLTOOL_UPDATE@
|
|
-INTLTOOL_V_MERGE = @INTLTOOL_V_MERGE@
|
|
-INTLTOOL_V_MERGE_OPTIONS = @INTLTOOL_V_MERGE_OPTIONS@
|
|
-INTLTOOL__v_MERGE_ = @INTLTOOL__v_MERGE_@
|
|
-INTLTOOL__v_MERGE_0 = @INTLTOOL__v_MERGE_0@
|
|
LD = @LD@
|
|
LDFLAGS = @LDFLAGS@
|
|
-LIBICONV = @LIBICONV@
|
|
-LIBINTL = @LIBINTL@
|
|
LIBOBJS = @LIBOBJS@
|
|
LIBS = @LIBS@
|
|
LIBTOOL = @LIBTOOL@
|
|
LIPO = @LIPO@
|
|
LN_S = @LN_S@
|
|
-LTLIBICONV = @LTLIBICONV@
|
|
-LTLIBINTL = @LTLIBINTL@
|
|
LTLIBOBJS = @LTLIBOBJS@
|
|
LXPANEL_MODULE = @LXPANEL_MODULE@
|
|
MAKEINFO = @MAKEINFO@
|
|
@@ -306,8 +205,6 @@
|
|
STRIP = @STRIP@
|
|
USE_NLS = @USE_NLS@
|
|
VERSION = @VERSION@
|
|
-WNCK_CFLAGS = @WNCK_CFLAGS@
|
|
-WNCK_LIBS = @WNCK_LIBS@
|
|
X11_CFLAGS = @X11_CFLAGS@
|
|
X11_LIBS = @X11_LIBS@
|
|
XGETTEXT = @XGETTEXT@
|
|
@@ -348,8 +245,6 @@
|
|
includedir = @includedir@
|
|
infodir = @infodir@
|
|
install_sh = @install_sh@
|
|
-intltool__v_merge_options_ = @intltool__v_merge_options_@
|
|
-intltool__v_merge_options_0 = @intltool__v_merge_options_0@
|
|
libdir = @libdir@
|
|
libexecdir = @libexecdir@
|
|
localedir = @localedir@
|
|
@@ -421,9 +316,9 @@
|
|
$(ACLOCAL_M4): $(am__aclocal_m4_deps)
|
|
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
|
|
$(am__aclocal_m4_deps):
|
|
-
|
|
install-moduleLTLIBRARIES: $(module_LTLIBRARIES)
|
|
@$(NORMAL_INSTALL)
|
|
+ test -z "$(moduledir)" || $(MKDIR_P) "$(DESTDIR)$(moduledir)"
|
|
@list='$(module_LTLIBRARIES)'; test -n "$(moduledir)" || list=; \
|
|
list2=; for p in $$list; do \
|
|
if test -f $$p; then \
|
|
@@ -431,8 +326,6 @@
|
|
else :; fi; \
|
|
done; \
|
|
test -z "$$list2" || { \
|
|
- echo " $(MKDIR_P) '$(DESTDIR)$(moduledir)'"; \
|
|
- $(MKDIR_P) "$(DESTDIR)$(moduledir)" || exit 1; \
|
|
echo " $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(INSTALL) $(INSTALL_STRIP_FLAG) $$list2 '$(DESTDIR)$(moduledir)'"; \
|
|
$(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(INSTALL) $(INSTALL_STRIP_FLAG) $$list2 "$(DESTDIR)$(moduledir)"; \
|
|
}
|
|
@@ -448,16 +341,13 @@
|
|
|
|
clean-moduleLTLIBRARIES:
|
|
-test -z "$(module_LTLIBRARIES)" || rm -f $(module_LTLIBRARIES)
|
|
- @list='$(module_LTLIBRARIES)'; \
|
|
- locs=`for p in $$list; do echo $$p; done | \
|
|
- sed 's|^[^/]*$$|.|; s|/[^/]*$$||; s|$$|/so_locations|' | \
|
|
- sort -u`; \
|
|
- test -z "$$locs" || { \
|
|
- echo rm -f $${locs}; \
|
|
- rm -f $${locs}; \
|
|
- }
|
|
-
|
|
-thermal.la: $(thermal_la_OBJECTS) $(thermal_la_DEPENDENCIES) $(EXTRA_thermal_la_DEPENDENCIES)
|
|
+ @list='$(module_LTLIBRARIES)'; for p in $$list; do \
|
|
+ dir="`echo $$p | sed -e 's|/[^/]*$$||'`"; \
|
|
+ test "$$dir" != "$$p" || dir=.; \
|
|
+ echo "rm -f \"$${dir}/so_locations\""; \
|
|
+ rm -f "$${dir}/so_locations"; \
|
|
+ done
|
|
+thermal.la: $(thermal_la_OBJECTS) $(thermal_la_DEPENDENCIES)
|
|
$(AM_V_CCLD)$(thermal_la_LINK) -rpath $(moduledir) $(thermal_la_OBJECTS) $(thermal_la_LIBADD) $(LIBS)
|
|
|
|
mostlyclean-compile:
|
|
@@ -471,30 +361,34 @@
|
|
.c.o:
|
|
@am__fastdepCC_TRUE@ $(AM_V_CC)$(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
|
|
@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
|
|
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
|
|
+@am__fastdepCC_FALSE@ $(AM_V_CC) @AM_BACKSLASH@
|
|
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
|
|
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
|
-@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(COMPILE) -c -o $@ $<
|
|
+@am__fastdepCC_FALSE@ $(COMPILE) -c $<
|
|
|
|
.c.obj:
|
|
@am__fastdepCC_TRUE@ $(AM_V_CC)$(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `$(CYGPATH_W) '$<'`
|
|
@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
|
|
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
|
|
+@am__fastdepCC_FALSE@ $(AM_V_CC) @AM_BACKSLASH@
|
|
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
|
|
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
|
-@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(COMPILE) -c -o $@ `$(CYGPATH_W) '$<'`
|
|
+@am__fastdepCC_FALSE@ $(COMPILE) -c `$(CYGPATH_W) '$<'`
|
|
|
|
.c.lo:
|
|
@am__fastdepCC_TRUE@ $(AM_V_CC)$(LTCOMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
|
|
@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Plo
|
|
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
|
|
+@am__fastdepCC_FALSE@ $(AM_V_CC) @AM_BACKSLASH@
|
|
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
|
|
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
|
-@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(LTCOMPILE) -c -o $@ $<
|
|
+@am__fastdepCC_FALSE@ $(LTCOMPILE) -c -o $@ $<
|
|
|
|
thermal_la-thermal.lo: thermal.c
|
|
@am__fastdepCC_TRUE@ $(AM_V_CC)$(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(thermal_la_CFLAGS) $(CFLAGS) -MT thermal_la-thermal.lo -MD -MP -MF $(DEPDIR)/thermal_la-thermal.Tpo -c -o thermal_la-thermal.lo `test -f 'thermal.c' || echo '$(srcdir)/'`thermal.c
|
|
@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/thermal_la-thermal.Tpo $(DEPDIR)/thermal_la-thermal.Plo
|
|
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='thermal.c' object='thermal_la-thermal.lo' libtool=yes @AMDEPBACKSLASH@
|
|
+@am__fastdepCC_FALSE@ $(AM_V_CC) @AM_BACKSLASH@
|
|
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='thermal.c' object='thermal_la-thermal.lo' libtool=yes @AMDEPBACKSLASH@
|
|
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
|
-@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(thermal_la_CFLAGS) $(CFLAGS) -c -o thermal_la-thermal.lo `test -f 'thermal.c' || echo '$(srcdir)/'`thermal.c
|
|
+@am__fastdepCC_FALSE@ $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(thermal_la_CFLAGS) $(CFLAGS) -c -o thermal_la-thermal.lo `test -f 'thermal.c' || echo '$(srcdir)/'`thermal.c
|
|
|
|
mostlyclean-libtool:
|
|
-rm -f *.lo
|
|
@@ -502,15 +396,26 @@
|
|
clean-libtool:
|
|
-rm -rf .libs _libs
|
|
|
|
-ID: $(am__tagged_files)
|
|
- $(am__define_uniq_tagged_files); mkid -fID $$unique
|
|
-tags: tags-am
|
|
-TAGS: tags
|
|
+ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
|
|
+ list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
|
|
+ unique=`for i in $$list; do \
|
|
+ if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
|
|
+ done | \
|
|
+ $(AWK) '{ files[$$0] = 1; nonempty = 1; } \
|
|
+ END { if (nonempty) { for (i in files) print i; }; }'`; \
|
|
+ mkid -fID $$unique
|
|
+tags: TAGS
|
|
|
|
-tags-am: $(TAGS_DEPENDENCIES) $(am__tagged_files)
|
|
+TAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
|
|
+ $(TAGS_FILES) $(LISP)
|
|
set x; \
|
|
here=`pwd`; \
|
|
- $(am__define_uniq_tagged_files); \
|
|
+ list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
|
|
+ unique=`for i in $$list; do \
|
|
+ if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
|
|
+ done | \
|
|
+ $(AWK) '{ files[$$0] = 1; nonempty = 1; } \
|
|
+ END { if (nonempty) { for (i in files) print i; }; }'`; \
|
|
shift; \
|
|
if test -z "$(ETAGS_ARGS)$$*$$unique"; then :; else \
|
|
test -n "$$unique" || unique=$$empty_fix; \
|
|
@@ -522,11 +427,15 @@
|
|
$$unique; \
|
|
fi; \
|
|
fi
|
|
-ctags: ctags-am
|
|
-
|
|
-CTAGS: ctags
|
|
-ctags-am: $(TAGS_DEPENDENCIES) $(am__tagged_files)
|
|
- $(am__define_uniq_tagged_files); \
|
|
+ctags: CTAGS
|
|
+CTAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
|
|
+ $(TAGS_FILES) $(LISP)
|
|
+ list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
|
|
+ unique=`for i in $$list; do \
|
|
+ if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
|
|
+ done | \
|
|
+ $(AWK) '{ files[$$0] = 1; nonempty = 1; } \
|
|
+ END { if (nonempty) { for (i in files) print i; }; }'`; \
|
|
test -z "$(CTAGS_ARGS)$$unique" \
|
|
|| $(CTAGS) $(CTAGSFLAGS) $(AM_CTAGSFLAGS) $(CTAGS_ARGS) \
|
|
$$unique
|
|
@@ -535,21 +444,6 @@
|
|
here=`$(am__cd) $(top_builddir) && pwd` \
|
|
&& $(am__cd) $(top_srcdir) \
|
|
&& gtags -i $(GTAGS_ARGS) "$$here"
|
|
-cscopelist: cscopelist-am
|
|
-
|
|
-cscopelist-am: $(am__tagged_files)
|
|
- list='$(am__tagged_files)'; \
|
|
- case "$(srcdir)" in \
|
|
- [\\/]* | ?:[\\/]*) sdir="$(srcdir)" ;; \
|
|
- *) sdir=$(subdir)/$(srcdir) ;; \
|
|
- esac; \
|
|
- for i in $$list; do \
|
|
- if test -f "$$i"; then \
|
|
- echo "$(subdir)/$$i"; \
|
|
- else \
|
|
- echo "$$sdir/$$i"; \
|
|
- fi; \
|
|
- done >> $(top_builddir)/cscope.files
|
|
|
|
distclean-tags:
|
|
-rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags
|
|
@@ -601,15 +495,10 @@
|
|
|
|
installcheck: installcheck-am
|
|
install-strip:
|
|
- if test -z '$(STRIP)'; then \
|
|
- $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
|
|
- install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
|
|
- install; \
|
|
- else \
|
|
- $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
|
|
- install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
|
|
- "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'" install; \
|
|
- fi
|
|
+ $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
|
|
+ install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
|
|
+ `test -z '$(STRIP)' || \
|
|
+ echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
|
|
mostlyclean-generic:
|
|
|
|
clean-generic:
|
|
@@ -694,20 +583,19 @@
|
|
|
|
.MAKE: install-am install-strip
|
|
|
|
-.PHONY: CTAGS GTAGS TAGS all all-am check check-am clean clean-generic \
|
|
- clean-libtool clean-moduleLTLIBRARIES cscopelist-am ctags \
|
|
- ctags-am distclean distclean-compile distclean-generic \
|
|
- distclean-libtool distclean-tags distdir dvi dvi-am html \
|
|
- html-am info info-am install install-am install-data \
|
|
- install-data-am install-dvi install-dvi-am install-exec \
|
|
- install-exec-am install-html install-html-am install-info \
|
|
- install-info-am install-man install-moduleLTLIBRARIES \
|
|
- install-pdf install-pdf-am install-ps install-ps-am \
|
|
- install-strip installcheck installcheck-am installdirs \
|
|
- maintainer-clean maintainer-clean-generic mostlyclean \
|
|
- mostlyclean-compile mostlyclean-generic mostlyclean-libtool \
|
|
- pdf pdf-am ps ps-am tags tags-am uninstall uninstall-am \
|
|
- uninstall-moduleLTLIBRARIES
|
|
+.PHONY: CTAGS GTAGS all all-am check check-am clean clean-generic \
|
|
+ clean-libtool clean-moduleLTLIBRARIES ctags distclean \
|
|
+ distclean-compile distclean-generic distclean-libtool \
|
|
+ distclean-tags distdir dvi dvi-am html html-am info info-am \
|
|
+ install install-am install-data install-data-am install-dvi \
|
|
+ install-dvi-am install-exec install-exec-am install-html \
|
|
+ install-html-am install-info install-info-am install-man \
|
|
+ install-moduleLTLIBRARIES install-pdf install-pdf-am \
|
|
+ install-ps install-ps-am install-strip installcheck \
|
|
+ installcheck-am installdirs maintainer-clean \
|
|
+ maintainer-clean-generic mostlyclean mostlyclean-compile \
|
|
+ mostlyclean-generic mostlyclean-libtool pdf pdf-am ps ps-am \
|
|
+ tags uninstall uninstall-am uninstall-moduleLTLIBRARIES
|
|
|
|
|
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|