freebsd-ports/lang/squeak/files/patch-platforms__unix__npsqueak__Makefile
Martin Wilke c04df41256 - Update to 3.9-7
PR:		126298
Submitted by:	Takeshi MUTOH <mutoh@openedu.org> (maintainer)
2008-08-25 21:04:41 +00:00

20 lines
690 B
Text

--- platforms/unix/npsqueak/Makefile.orig Sat Aug 23 06:59:39 2003
+++ platforms/unix/npsqueak/Makefile Fri Nov 24 18:55:48 2006
@@ -3,7 +3,7 @@
############ Customize flags here #######################
-INC = -I./include -I/usr/X11R6/include
+INC = -I./include -I%%LOCALBASE%%/include
CC = gcc
CFLAGS = $(INC) -O2 -fPIC -Wall
LD = gcc
@@ -20,7 +20,7 @@
############ compile and link ###########################
npsqueak.so : npsqueak.o npunix.o
- $(LD) $(LDFLAGS) npsqueak.o npunix.o -o npsqueak.so
+ $(LD) $(LDFLAGS) npsqueak.o npunix.o -o npsqueak.so -L%%LOCALBASE%%/lib -lXt -lX11
npsqueak.o: npsqueak.c ../config.h
$(CC) -c $(CFLAGS) -DVM_LIBDIR=\"$(VM_LIBDIR)\" $<