freebsd-ports/sysutils/kshutdown-kde4/files/patch-src__CMakeLists.txt
Max Brazhnikov 18e40a0c85 sysutils/kshutdown-kde4:
- update to 3.2, requires decent compiler for build
- switch to outsource build
- remove USE_KDE4=kdehier (will be deprecated soon)
- add patch to fix stripping during install stage
- drop @dirrm from plist
2014-10-12 20:23:23 +00:00

14 lines
480 B
Text

--- src/CMakeLists.txt.orig 2014-10-12 13:00:51 UTC
+++ src/CMakeLists.txt
@@ -47,10 +47,7 @@
target_link_libraries(kshutdown kdecore kdeui kio ${KDE4_KNOTIFYCONFIG_LIBS} ${KDE4_KUTILS_LIBS})
-install(
- PROGRAMS "${CMAKE_CURRENT_BINARY_DIR}/kshutdown"
- DESTINATION bin
-)
+install(TARGETS kshutdown RUNTIME DESTINATION bin)
install(FILES kshutdown.desktop DESTINATION ${XDG_APPS_INSTALL_DIR})
install(FILES kshutdown.notifyrc DESTINATION ${DATA_INSTALL_DIR}/kshutdown)