6.8.0: - In bgpctl(8), the "reload" command now takes a 'reason' argument to use as Administrative Shutdown Communication to its neighbors. - Added bgpctl(8) support for VPNv6 in the family option of the "show rib" command. - Added bgpctl(8) support for JSON formatted output in various "show" commands. - Support to build OpenBGPD on Alpine Linux added 6.7.0: - Add initial support for JSON output in bgpctl(8). - Allow setting both IPv4 and IPv6 local-addresses at the same time in bgpd.conf group blocks. Introduced 'no local-address' to reset a previously set local address. - Properly aggregate duplicate bgpd(8) roa table prefix/source-as combinations into a single entry with the longest maxlen length. - Implemented bgpd.conf(5) max-prefix NUM out to limit the number of announced prefixes, avoiding leaks of full tables to upstreams and peers. - Extended bgpctl(8) 'show neighbor' to include the received and set prefix count, as well as the max-prefix out limit if set. - Improved reporting of notifications to include the suberror cause. - Also report the last received error cause in bgpctl(8) show neighbor output. - Fix softreconfig out handling to also work for neighbors using 'export default-route'. - Mark stale prefixes in the Adj-RIB-Out so that graceful reload operates properly. - Made it possible to build OpenBGPD-portable with bison. There is no longer the need to use byacc on Linux distributions. - Support for --runstatedir to specify the location of the bgpctl.sock. - Cleaned up configure script for better protability. See also: https://github.com/openbgpd-portable/openbgpd-portable/issues/8 PR: 250274
22 lines
868 B
Text
22 lines
868 B
Text
--- Makefile.am.orig 2020-05-05 08:36:21 UTC
|
|
+++ Makefile.am
|
|
@@ -19,13 +19,16 @@ ACLOCAL_AMFLAGS = -I m4
|
|
EXTRA_DIST = README.md LICENSE VERSION bgpd.conf
|
|
|
|
install-data-hook:
|
|
- @if [ ! -d "$(DESTDIR)$(runstatedir)" ]; then \
|
|
+ if [ ! -d "$(DESTDIR)$(runstatedir)" ]; then \
|
|
$(INSTALL) -m 755 -d "$(DESTDIR)$(runstatedir)"; \
|
|
fi
|
|
- @if [ ! -d "$(DESTDIR)$(sysconfdir)" ]; then \
|
|
+ if [ ! -d "$(DESTDIR)$(sysconfdir)" ]; then \
|
|
$(INSTALL) -m 755 -d "$(DESTDIR)$(sysconfdir)"; \
|
|
fi
|
|
- @if [ ! -f "$(DESTDIR)$(sysconfdir)/bgpd.conf" ]; then \
|
|
+ if [ ! -f "$(DESTDIR)$(sysconfdir)/bgpd.conf.sample" ]; then \
|
|
+ $(INSTALL) -m 644 "$(srcdir)/bgpd.conf" "$(DESTDIR)$(sysconfdir)/bgpd.conf.sample"; \
|
|
+ fi
|
|
+ if [ ! -f "$(DESTDIR)$(sysconfdir)/bgpd.conf" ]; then \
|
|
$(INSTALL) -m 644 "$(srcdir)/bgpd.conf" "$(DESTDIR)$(sysconfdir)/bgpd.conf"; \
|
|
else \
|
|
echo; \
|