freebsd-ports/databases/mariadb101-server/files/patch-include_CMakeLists.txt
Bernard Spil eaba6fd276 [NEW PORTS] databases/mariadb101-{server,client}: 10.1.11
MariaDB is one of the most popular database servers in the world. It's made
by the original developers of MySQL and guaranteed to stay open source.
Notable users include Wikipedia, Facebook and Google.

MariaDB turns data into structured information in a wide array of
applications, ranging from banking to websites. It is an enhanced, drop-in
replacement for MySQL. MariaDB is used because it is fast, scalable and
robust, with a rich ecosystem of storage engines, plugins and many other
tools make it very versatile for a wide variety of use cases.

MariaDB is developed as open source software and as a relational database
it provides an SQL interface for accessing data. This latest versions of
MariaDB also include GIS and JSON features.

WWW: http://mariadb.org/

Reviewed by:	koobs (mentor), feld (mentor)
Approved by:	koobs (mentor), feld (mentor)
Differential Revision:	D3953
2016-02-13 19:02:11 +00:00

26 lines
966 B
Text

Fix up missing WITHOUT_DOCS, WITHOUT_CLIENT options
--- include/CMakeLists.txt.orig 2015-10-15 15:43:36 UTC
+++ include/CMakeLists.txt
@@ -62,17 +62,21 @@ SET(HEADERS
handler_ername.h
)
+IF(FALSE)
INSTALL(FILES ${HEADERS} DESTINATION ${INSTALL_INCLUDEDIR} COMPONENT Development)
FOREACH(f ${HEADERS_GEN_CONFIGURE})
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/${f} DESTINATION ${INSTALL_INCLUDEDIR} COMPONENT Development PERMISSIONS OWNER_READ GROUP_READ WORLD_READ)
ENDFOREACH(f)
INSTALL(DIRECTORY mysql/ DESTINATION ${INSTALL_INCLUDEDIR} COMPONENT Development FILES_MATCHING PATTERN "*.h")
+ENDIF()
STRING(REPLACE "." "\\." EXCL_RE "${HEADERS};${HEADERS_GEN_CONFIGURE}")
STRING(REPLACE ";" "|" EXCL_RE "${EXCL_RE}")
+IF(FALSE)
INSTALL(DIRECTORY . DESTINATION ${INSTALL_INCLUDEDIR}/private COMPONENT Development
FILES_MATCHING PATTERN "*.h"
PATTERN CMakeFiles EXCLUDE
PATTERN mysql EXCLUDE
REGEX "\\./(${EXCL_RE}$)" EXCLUDE)
+ENDIF()