- builds on i386 now - remove MAKE_JOBS_UNSAFE - Upstream wsjtx build instructions call for their forked version of hamlib for wsjtx to work correctly. Upstream distribution includes both wsjtx and a copy of their forked hamlib with their own build system. This is now used in this updated port. The cmake build provided does not have an install/strip target which forces use of do-install. N.B. If hamlib is already installed, this port will incorrectly link against the shared library version of hamlib instead of the private copy provided. There seems no easy solution to this.
20 lines
1 KiB
Text
20 lines
1 KiB
Text
--- CMakeLists.txt.orig 2019-02-25 04:11:18 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -23,7 +23,7 @@ source tarball." )
|
|
#
|
|
# Find_library (USB_LIBRARY NAMES libusb.a usb)
|
|
Find_program (PATCH_EXECUTABLE patch REQUIRED)
|
|
-Find_package (Git REQUIRED)
|
|
+#Find_package (Git REQUIRED)
|
|
|
|
#
|
|
# extra C flags to minimize hamlib excutable sizes
|
|
@@ -91,7 +91,7 @@ ExternalProject_Add (hamlib
|
|
URL_HASH MD5=${hamlib_md5sum}
|
|
UPDATE_COMMAND ./bootstrap
|
|
PATCH_COMMAND ${PATCH_EXECUTABLE} -p1 -N < ${CMAKE_CURRENT_SOURCE_DIR}/hamlib.patch
|
|
- CONFIGURE_COMMAND <SOURCE_DIR>/configure --prefix=<INSTALL_DIR> --disable-shared --enable-static --without-cxx-binding ${EXTRA_FLAGS} # LIBUSB_LIBS=${USB_LIBRARY}
|
|
+ CONFIGURE_COMMAND <SOURCE_DIR>/configure --prefix=<INSTALL_DIR> --disable-shared --enable-static --without-cxx-binding --without-readline ${EXTRA_FLAGS} # LIBUSB_LIBS=${USB_LIBRARY}
|
|
BUILD_COMMAND $(MAKE) all V=1 # $(MAKE) is ExternalProject_Add() magic to do recursive make
|
|
INSTALL_COMMAND $(MAKE) install-strip V=1 DESTDIR=""
|
|
STEP_TARGETS update install
|