original versions of these ports, so some PORTREVISIONs were bumped. See http://freebsd.kde.org/ and mailing lists linked to from there for info on the packages generated to test these ports. bsd.kde.mk has already been updated a few days ago to work with these. Some patches applied to fix a few bugs were: deskutils/kdepim3: [1] Remove kpilot from build because it wasn't ready at release. editors/koffice-kde3: [2] Fix compile time bugs for FreeBSD. misc/kdeedu3: [3] Fix compile problem with kvoctrain. x11/kdebase3: [4] Fix KDM CPU usage and login bug. Some caveats: * All PLISTs are broken for deinstall due to script bug that I didn't notice until very recently. This will be fixed when I commit an update tomorrow. These ports should still install perfectly fine though. They should also deinstall without giving errors, but will leave directories behind. * You can't install this with any other version of QT or KDE already installed. I am not sure the checks are 100% working, but fixes for these will be forthcoming. This is mainly due to a policy decision made by kde@ to make QT/KDE ports install the way the rest of the world expects it to while also still conforming to FreeBSD's hier(7). For reference on this decision, please consult the KDE/FreeBSD mailing list archives. This decision fixes 2-year-old bug reports relating to how we handled this for KDE2 vs KDE1. Submitted by: [1] Adrian de Groot <adridg@cs.kun.nl>, [2] David Faure <faure@kde.org>, Andy Fawcett <andy@athame.co.uk> Lauri Watts <lauri@kde.org> [3] Lauri Watts <lauri@kde.org> [4] Alan Eldridge <alane@geeksrus.net> Oswald Buddenhagen <ossi@kde.org> Reviewed by: kde
16 lines
674 B
Text
16 lines
674 B
Text
Index: filters/kontour/wmf/Makefile.am
|
|
===================================================================
|
|
RCS file: /home/kde/koffice/filters/kontour/wmf/Makefile.am,v
|
|
retrieving revision 1.4
|
|
diff -u -3 -p -r1.4 Makefile.am
|
|
--- filters/kontour/wmf/Makefile.am 2001/03/22 14:02:18 1.4
|
|
+++ filters/kontour/wmf/Makefile.am 2002/04/02 17:01:41
|
|
@@ -1,7 +1,7 @@
|
|
####### General stuff
|
|
|
|
INCLUDES= -I$(srcdir) $(KWMF_INCLUDES) $(KOFFICE_INCLUDES) $(all_includes)
|
|
-libwmfimport_la_LDFLAGS = -module -avoid-version -no-undefined
|
|
+libwmfimport_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
|
|
libwmfimport_la_LIBADD = $(KOFFICE_LIBS) $(LIB_KWMF)
|
|
|
|
####### Files
|