freebsd-ports/security/fressh/files/patch-lib::Makefile
Maxim Sobolev 914972d462 Add fressh 0.8.1, a free rewritten implementation of the SSH
communication protocol.

Obtained from:	NetBSD
2001-04-18 16:24:18 +00:00

40 lines
1.1 KiB
Text

$FreeBSD$
--- lib/Makefile 2001/04/18 15:56:18 1.1
+++ lib/Makefile 2001/04/18 15:56:44
@@ -1,8 +1,8 @@
# $Id: Makefile,v 1.1 2001/04/18 15:56:18 root Exp root $
NOLINT = 1
-DEBUG = -g
-OPTIMIZE = -O2
+#DEBUG = -g
+#OPTIMIZE = -O2
LIB = ssh
NOPIC = 1
@@ -10,9 +10,9 @@
.PATH: ${.CURDIR}/../transport
.PATH: ${.CURDIR}/../crypto
-WARNINGS = -Wall -Wstrict-prototypes -Wmissing-prototypes \
- -Wpointer-arithmetic -Wreturn-type -Wwrite-strings \
- -Wcast-qual -Wswitch -Werror # -Wshadow
+#WARNINGS = -Wall -Wstrict-prototypes -Wmissing-prototypes \
+# -Wpointer-arithmetic -Wreturn-type -Wwrite-strings \
+# -Wcast-qual -Wswitch -Werror # -Wshadow
# DEFINES += -DUNSAFE_DEBUG
# DEFINES += -DFORCE_VALID_LOOPBACK_HOST_KEYS
# DEFINES += -DNO_CRC_AT_ALL
@@ -20,8 +20,8 @@
INCLUDE = -I${.CURDIR}/.. -I${.CURDIR}/../transport -I${.CURDIR}/../crypto
-CPPFLAGS = ${WARNINGS} ${INCLUDE} ${MEMDEBUG_INCLUDE}
-CFLAGS = ${DEBUG} ${OPTIMIZE} ${CPPFLAGS}
+CPPFLAGS += ${WARNINGS} ${INCLUDE} ${MEMDEBUG_INCLUDE}
+CFLAGS += ${DEBUG} ${OPTIMIZE} ${CPPFLAGS}
OS_SRC = ssh_sys_bsd44+.c ssh_sys_posix.c