freebsd-ports/x11/kde4-workspace/files/patch-CMakeLists.txt
Alberto Villa a2d3b5a4bc The KDE/FreeBSD team is pleased to announce KDE Software Compilation
4.7.2. The official release notes can be found at:
http://kde.org/announcements/announce-4.7.2.php
This release ships with many improvements. Read more about them here:
http://FreeBSD.kde.org/news.php#itemKDESC472availableinports

We'd like to say thanks to all testers and contributors, especially to
lwhsu@ for his effort on hosting our test packages.

PR:		156293 [1]
		159219 [2]
		160164 [3]
Submitted by:	Oleg Sidorkin <osidorkin@gmail.com> [1]
		Alvaro Castillo <gobledb@gmail.com> [2]
		dkeav04@gmail.com [3]
Tested by:	exp-run via pav
2011-10-17 00:03:42 +00:00

11 lines
886 B
Text

--- ./CMakeLists.txt.orig 2011-07-19 23:37:36.000000000 +0200
+++ ./CMakeLists.txt 2011-08-09 20:45:40.975563521 +0200
@@ -90,7 +90,7 @@
configure_file(config-unix.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-unix.h )
configure_file(config-X11.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-X11.h )
if(NOT CMAKE_INSTALL_PREFIX STREQUAL "/usr")
- set(EXPORT_XCURSOR_PATH "XCURSOR_PATH=${CMAKE_INSTALL_PREFIX}/share/icons:$XCURSOR_PATH\":~/.icons:/usr/share/icons:/usr/share/pixmaps:/usr/X11R6/lib/X11/icons\"; export XCURSOR_PATH")
+ set(EXPORT_XCURSOR_PATH "XCURSOR_PATH=${CMAKE_INSTALL_PREFIX}/share/icons:$XCURSOR_PATH\":~/.icons:/usr/local/share/icons:/usr/local/share/pixmaps:/usr/local/lib/X11/icons\"; export XCURSOR_PATH")
endif(NOT CMAKE_INSTALL_PREFIX STREQUAL "/usr")
configure_file(startkde.cmake ${CMAKE_CURRENT_BINARY_DIR}/startkde @ONLY)
endif(NOT WIN32)